Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
75 Posts
Discussion Starter #1
Hi All

Just ordered a new Bosch battery as my current one does not seem to be holding its charge very well. Is there anything I need to be carefull of when fitting the new one ? Or should I be able to simply remove one then fit the new one ?
 

·
Registered
Joined
·
30,171 Posts
Just always remove the -ve FIRST and refit the -ve LAST.
 

·
Registered
Joined
·
75 Posts
Discussion Starter #5
Thanks lads. Just standard swop over then.

Was not sure if would need some sort of engine code. Glad don't as I don't have one !!!
 

·
Registered
Joined
·
28,482 Posts
All sorted then hopefully. Makes a huge difference having a new battery fitted in fact.......:thumbs:
 

·
Registered
Joined
·
75 Posts
Discussion Starter #10
Hi there

Wish I was sorted but still waiting for the battery to be delivered. Had expected it to be here by now but so far no sign. Can't wait as the spider is just sitting there until i can get the replacement fitted. Still keeping me fingers crossed. !!!:cry::cry:
 

·
Registered
Joined
·
75 Posts
Discussion Starter #13
Hi lads,

Replaced the radio when I got the car. Got one with bluetooth, MP3 input and SD card sloy. Much better sound also. But navigations through the tracks not easy. Never mind was pretty cheap. Battery delivered this morning, hour later she started up no problem. Yippee !!! now just hope it was the battery and not something else draining it. Any way means I got me spider back :)
 

·
Registered
Joined
·
75 Posts
Discussion Starter #14
Forgot to mention, only little thing was the srivers window did not close properly afterwards. Started the car again and operated windows up and down from inside switches. This seemed to sort it out as when got out of car the window fully closed. Great!!
 
1 - 14 of 14 Posts
Top