Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
Hi Folks
I'm restoring my 2.4 JTD SW (2001) to health after a silly mechanic, while doing a service, overtightened the the nuts on the air filter lid. The lugs cracked, the lid shook free, the Maf gave up, and perhaps other things too !. 12 months down the road my wonderful 2.4 would start from cold run for 15-20 minutes stop (at whatever speed it was going) and would only restart when cool 20 min later.
Ok, so the lid is now not attaching, the box is good and I have a new Bosch MAF. Can I fit a Apiro Torque filter -Red in to the box snugly, are there any issues with the MAF sitting above the top of the filter and is it necessary ( or sensible) to adress the rest of the induction system, pipework, tubes and so forth. I'm not to worried about performance enhncement just my lovely 2.4 back the way it was
 

·
Registered
Joined
·
30,222 Posts
12 months down the road my wonderful 2.4 would start from cold run for 15-20 minutes stop (at whatever speed it was going) and would only restart when cool 20 min later.
That is likely to be a failing crank sensor.

When they fail, they fail when hot, cutting the engine. When the sensor has cooled, the engine can be started again.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
Thank you David C, I supposed as much from lots of advice and have a sensor on order. However I have to restore the integrity of the air intake as well and even though there's a lot on GTA and 3.0 lt there seems to be little on the diesel with all it's turbo bits and like that.
What a learning curve for me; last car I worked on was a 1971 MG midget! Still it's great fun.
 

·
Registered
Joined
·
18 Posts
Discussion Starter #4
Since there's no reply on the question of the MAF meter and the cone filter on my 2.4 10v, I'assuming there's not any issues with it and shall go ahead. Thanks to david c for advice on the crank sensor, Will I have to remove the battery tray and intercooler hose to get at it? Now is the time as I have to remove the battery anyway and have it replaced (Any suggestions of what to go for). Also while all that tin is off what else should be done? Perhaps a nut top hose in cylicone? Any other sensors or bits to be cleaned. The car is 2001 with 185000 miles on the clock.
 
1 - 4 of 4 Posts
Top