Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
303 Posts
Discussion Starter #1
Just thought I'd share this with forum.

I had loads of problems with my G3 nav unit, it kept giving 'CD Error' radomly. So going on what I read about errors on cd drives, I replaced the laser, at a cost of about £30 + shipping, but didn't help things, even tried an original alfa disk to see if that helped, nope.

So looking through other bulletin boards with similar systems, (opel/vauxhall/porsche)found a site via the Opel club that sold replacement CD drives for the Nav unit, albeit at 280 euro's!

So off to ebay I found an old Opel/Vauxhall nav unit, a NCDR 2011, pulled the cd drive out of it, swapped the two ribbon cables and support bracket, and bingo it works perfectly again, and only cost me £40!

So if anyone else needs to replace a dodgy cd drive in their nav unit any one from the NCDR 1100/1300/1500/2011/2013/2015 series will do, and it doesn't matter if the doner unit has a code or not, as the code is stored in the main board of the nav unit not the cd drive.
 

·
Administrator
GT 2.0 JTS
Joined
·
5,175 Posts
I have a problem at the moment with mine, it will not display the map on the ics screen, all other functions ie planning, direction arrows and voice commands work. At first the map started to break up, then went completely off.
 

·
Registered
Joined
·
6,165 Posts
Hello Mark, how are you?

Good post, mine struggles in the damp (after rain and the cold) could do with being fixed.

Not seen you about for ages.


Do you still happen to have those stalks handy? Ive got time to collect them now - its been about two years lol. No worries if not.
 
1 - 3 of 3 Posts
Top