Alfa Romeo Forum banner

1 - 11 of 11 Posts
B

·
Guest
Joined
·
0 Posts
Discussion Starter #1
ok.. any tips? i was attempting to take it out to fit the chip, took the black cover off.. and thought bugger this... looks a right old job to get it out. Also, a couple of the nuts are missing on (no jokes please) it leading me to belive it may have been out before, perhaps chipped already.
 

·
Registered
Joined
·
4,651 Posts
BUG it only takes 10mins to get the ecu out

take off the platic cover and then theres two bolts holding it in you need to wiggle it to get it out and then unplug the wiring then just bend the tabs to open the ecu

Or go to the Squadra site and read the online fitting instructions :D :D
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #4
On my 8 valve the ECU is held in place with a lever type mechanism. Undo the bolts, move the lever and it plops down. The rest is the same as Speedy says. The two screws in the middle of the ECU don't need to be undone.

Marlon
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Screws in the middle hold the circuit board in place I think. I had to dismantle the whole lot recently when I had the water problem :D Dwead easy wink

wrinx
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #6
still cant get it out.. there seem to be 4 nuts holding it in... but its so far under the glove box i cant get to them or see what the hell im doing..begining to get frustrated now
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #7
ok i cant seem to pull ot the ecu cos there are definately 4 bolts holding it in place.. then once id got those off id have to slip it forward off the bolt threads.. which would be hard in itself cos theres not enough space to pull it free... the top 2 bolts i cant get to becuse the glove box is in the way, plus ive kinna rendered my car undrivable cos i cant get the plug thing back into the bottom of the ECU.. im never going near a cars electrics again frown
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Not sure whats happening Bug, its a little tight but should come out ok after removing the bolts and levering off the connector.....try a bit more of the force wink

wrinx
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #10
speed freak:
BUG you are taking the bolts out that hold the ECU bracket in and not the bolts that hold the ecu casing on are`nt you
ooops..um probably.. but i dont see any other bolts or screws anywhere...ive taken the black cover off... once thats off..other thean the nuts holding the bracket in... i dont see anything else to unscrew.. :( where abouts would the nut/screw be located i have to take out? im gathering its gonna be really simple and im gonna seem even sillier than i do now! doh
 
F

·
Guest
Joined
·
0 Posts
Discussion Starter #11
you just need to remove the 4 LONG bolts which hold it to the bracket, move it up to get over the bracket & then detatch the Uber scart cable thing from the end (on clips) - then you can take it into the kitchen & fit the chip wink

A
 
1 - 11 of 11 Posts
Top