Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
280 Posts
Discussion Starter #1
Hi. After a rear end shunt and an insurance repair my 'ti' badge is in the wrong place! I know I could demand they fix it, but tbh I'd rather not let them near it again. Are the badges easy to remove without damaging the paint? I wonder if a hairdryer would help by applying some heat? I notice on the detailing forum someone 'knocked it off' whilst waxing. Also, how to reapply (avoiding superglue as per other thread!) ? Or am I better getting a replacement from eBay that comes with new adhesive backing?
 

·
Registered
Joined
·
13,247 Posts
If the beast comes off cleanly (use petrol to dissolve any residue.. but you might want to give the paint a week or two to properly/fully cure) then you can stick on the new badge with some contact adhesive.

I have used Evo-stick in the past.. the badge remains "removable" if you ever want/need to remove it and any glue residue is petrol-soluble rather than leaving any crust/hard glue on the paint.

Ralf S.
 

·
Registered
Joined
·
280 Posts
Discussion Starter #4
Cheers guys, doesn't sound too bad then. I'll post a pic later and you can join me wondering how and why they chose the position they did! Bizarrely they go to the trouble of 'recreating' the paint info label that is inside the tailgate, then slap the 'ti' on without too much thought....
 

·
Registered
Joined
·
13,247 Posts
Yes.. needs to be re-postioned. If you know someone who has one.. get them to measure the relative placing. The "ti" looks like it should be level with the bottom of the "159".. so it's lined up left-right okay (measure another one to make sure) but is way too high..


Ralf S.
 
1 - 6 of 6 Posts
Top