Alfa Romeo Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
591 Posts
Discussion Starter #1
Hi all, I have purchased myself active subwoofer to use in my mito. I have fitted many amps and subs before but that was on old crappy hatches with aftermarket head units. I want to do a proper job and need a bit of guidance. I am running the aux cable to a box which wires in to the rear speakers because i'm assuming new standard head units dont have aux out on the back of them. Now im not sure where to run the remote to, Im assuming there isnt anywhere on the headunit as its an standard modern one. Finally where would be the best place to run my live wire through the interior into the engine bay?

Thanks
 

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,713 Posts
Typically, the powerwire to the cigarette lighter is suitable. Access the plug at the rear (I haven't done this in a MiTo, so can't advise about it, sorry), and use a multimeter to confirm that it is 0V with ignition off, and goes to +12V when you insert the key and activate the car. Might be 3 wires: power, backlighting, ground.

Agree, I don't expect there are RCA outputs on the factory headunit (there aren't in any other Alfa's I've seen).

:)
 

·
AO Silver Member, 155 Lounge Winner 09
Joined
·
7,713 Posts
EDIT: double post
 

·
Registered
Joined
·
591 Posts
Discussion Starter #4
Thanks for the help, haven't considered there but it I remember rightly there's a cigarette power plug in the boot too :D
 
1 - 4 of 4 Posts
Top