Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
Ive had my 2006 147ti 150bhp diesel remapped by Celtic Tuning, it was quite smokey reasonably hard acceleration and was told it was having a clear out and maybe run some fuel cleaner through it.

A month or so later, in a well serviced maintained car its now not idling properly on start up when cold, a few days later ive noticed its now a bit blue smokey on starting. Im still leaving a fair amount of smoke brhind on acceleration. It had a new egr valve before it was remapped.

I havent spoken to Celtic Tuning yet, Im about to, but Id appreciate your advice on the smokiness post remap. Was pretty clean before.

cheers matt
 

·
Registered
Joined
·
1,951 Posts
How about worn injector? What are the injector correction values on diag?
 

·
Registered
Joined
·
551 Posts
I'd suggest that it might be the amount of fuel getting chucked in there post re-map, others may have a different view, but it sounds like it to me having seen the very same thing on another JTD engine in a different installation.
How many miles had the car (well, the engine) done prior to the re-map :confused: Could be that there's something a wee bit on the worn side, turbo.... injectors etc.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #4
oh yeah should have said..49k at remap. done 52k now. but thats because I do about 500/wk. thanks for your suggestions I'll bear those in mind
 

·
Registered
Joined
·
2,293 Posts
If it only smokes in high revs, then it is probably injectors fault. But if it smokes everywhere then it could be either some minor boost leak, turbo issue, or bad remap.
 

·
Registered
Joined
·
569 Posts
Mine lost about 80% of the smoke after I cleaned my map sensor and fully blocked the egr, If after this its still the same then injectors are a possibility also a poor map +1 to tribesman.
 

·
Registered
Joined
·
23 Posts
Discussion Starter #7
just a quick update. thanks for your help guys. I got it on a dyno. It seems it was quite poorly and underpowered. In the end I replaced the MAF and blanked off the EGR. I have a bottle of fuel cleaner running through at the moment. The power is up, its idling correctly, I suspect mpg is up a little (maybe 1 or 2 mpg) and the smokey black I leave hanging around is now a whispy grey only on the very heaviest of accelerations. I'll see how it goes, but I think I might be sorted. Can you believe my drivers door handle fell off!? Got that replaced. Brakes are a bit squeaky at times and my dash has a bad creak (if I press down on top of the dials at the front it stops), but at least its running better now :D
 

·
Registered
Joined
·
569 Posts
:)
 
1 - 8 of 8 Posts
Top