Alfa Romeo Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
309 Posts
Discussion Starter #1
I started to do the rear screen fix on my V6. Sure enough it had the usual melted fuse but the position of the relays in the fuse box was not what I expected.



The yellow timer relay is usually second top on the right. Has someone just moved it to disable the rear screen or is the one at the bottom doing something? It does click when the ignition is switched on but that only proves there's a 12V supply.
 

·
Registered
Joined
·
137 Posts
Yeah the yellow relay is in the wrong place. It is in a spot that is normally empty.

be sure to check a big yellow connector for melting on my car it was in the passenger footwell. i had to take the glove box out to get at it. it has brown and white wire that goes through the yellow G73B connector pin 9.
You can see a picture here https://www.alfaowner.com/Forum/alfa-gtv-andamp-916-spider/1100305-adrians-silver-1999-gtv-v6.html

If you dont have them the you can download the workshop manuals with full wiring diagrams.
 

Attachments

·
Registered
Joined
·
309 Posts
Discussion Starter #3
Yeah the yellow relay is in the wrong place. It is in a spot that is normally empty.

be sure to check a big yellow connector for melting on my car it was in the passenger footwell. i had to take the glove box out to get at it. it has brown and white wire that goes through the yellow G73B connector pin 9.
You can see a picture here https://www.alfaowner.com/Forum/alfa-gtv-andamp-916-spider/1100305-adrians-silver-1999-gtv-v6.html

If you dont have them the you can download the workshop manuals with full wiring diagrams.

Thanks - I have got the manuals but the wiring diagram is different to that so perhaps I have an early or late manual?
 
1 - 3 of 3 Posts
Top