Alfa Romeo Forum banner

41 - 50 of 50 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter #41
Cheers.

Delivered back home today and safely tucked up in the garage.




Dyno session booked next sat for running in and mapping the engine. Let's hope it doesn't lunch itself :ermm:
 

·
Registered
Joined
·
37 Posts
Discussion Starter #42
Got it out in the sun today to help cure the paint.

Cleaned dust form the engine / front although the body shop kept it very clean. Fitted front indicators and fogs.


 

·
Registered
Joined
·
37 Posts
Discussion Starter #45
Dyno yesterday. some issues related to the ECU's ability to control the DBW motor but we got it mapped up to 6500 rpm and we got just under 210hp at the wheels. There is another 1000 rpm and some ignition timing work to do and the mapping guy is predicting about 240 at the wheels. Which will be 280-90ish at the engine - just about what I was hoping expecting. No idea how accurate the dyno is.

On thing that was very noticeable from the plot was the torque after about 2500 rpm, there is lots of it and the overall area under the torque curve is large, so should make it good to drive.

Doesn't sound too bad either


So the issue with the DBW controlling the idle and therefore keeping emissions acceptable, it just won't do it. Seems like control on the ECU isn't fine enough. Might need a different ECU.....:grumpy:

Mind you, the engine ran faultlessly, got super hot and didn't spring a single leak or weep of anything. Nothing broke. So I can't complain there I guess.




So I'm a bit ****ed off that the ECU seems to be unsuitable for the application and that the car will not be on the road this summer but I need to look for some positives.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #46
Been a long time since I posted as progress has been slow and I've made a few changes.

Interior now trimmed.







We've changed the ECU for a Motec M130. Wiring loom had to be changed and will be going back into the car in a couple of weeks.

Also got some lovely equal length manifolds made by Extreme Tuning in Bulgaria!





Having a louder back box setup being made and collect that tomorrow.

Back on the dyno on 17th Feb to hopefully get it sorted finally.
 

·
Premium Member
Joined
·
400 Posts
Can you tell us a bit more on how you set up cam timing with your regrinds. Expected to see some adjustable pulleys and timing then optimised on your Dyno sessions?
 

·
Registered
Joined
·
37 Posts
Discussion Starter #48
The regrinds were done by Piper. They use the standard timing so you fit them as per the originals, no need for 'timing' as such. I might look at other cams in the future but I saw this as a quick and easy way of gaining a few extra HP. Until the car is through it's IVA and road registered I don't want cams that are too wild as I need to get it through emissions tests etc.
 

·
Registered
Joined
·
37 Posts
Discussion Starter #49
Another dyno session.....and another 'not quite there' result!







Motec M130 fitted and wiring loom modified to suit. Car now idles great and the ITB idle control from the new linkage setup is spot on. Twin lambdas working well too. However, the linkages won't open to 100% (only getting about 85%) so can't make full power, also getting some lash and slight sticking that's causing issues.

So still no idea what power it will put out
.

Plan is to rework the linkages, add some extra return springs on the DBW to help with the lash issues and then Daniel form CPS (who has wired and is mapping the car) will make the required changes remotely from Aus, where he now lives.

But once again the car was on the dyno for about 4 hours in total and (apart from the ITB linkage) showed no issues at all. No leaks, not noises, nothing went wrong! In fact this time the coolant temp was lower throughout and the oil temp was also a lot lower. We moved the oil temp sender to a remote filter head I fitted. I think previously it was getting heat soak from the EM but now it's far enough away to be reading a good 10-20 degrees lower. Didn't go over 110 today.

Manifolds were glowing orange a few times but no apparent issues with heat. DEI Gold reflective heat shield on the bulkhead is amazing, as is the zircoflex I put on the gear cables. Manifolds no longer nice and shiny!



So I might be OK for IVA once the linkages are sorted. Full power not needed and might be useful to help run the car in a bit. Will drop the running in oil now and change it for fully synth 10-60.

Couple of pulls

View on YouTube website

View on YouTube website
 
41 - 50 of 50 Posts
Top