Alfa Romeo Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Guys,

Another irritating niggle. A while back the lighting system warning light lit up on the dashboard. A blown fuse or bulb I thought. A thorough check indicated that all external lights were functioning. On closer inspection, however, I have now noticed that the rear offside tail light glows very slightly at all times - even with eveything, including the ignition switched off. When I turn the lights on, the dashbord warning light goes off; when I turn the lights off it comes on again. Unsurprisingly, this is draining my battery overnight. I have had to resort to pulling the lighting circuit fuse out every night to avoid a totally flat battery each morning. Any ideas very gratefully received.:confused:
 
G

·
Lots of different rev counters,make sure that it's the right one. Don't just assume that the one in the car is the correct one either, you can't count on it.
 

·
Registered
Joined
·
2 Posts
Hi,

A new rev counter is needed to fix this problem. Had the same problem with mine. Make sure the garage orders you the right one form the chas. no. the first one they orded for me was for a petrol car not much good for my diesel !!! Should cost you about £150 inc VAT.

Adrian
 

·
Registered
Joined
·
1,614 Posts
Lots of different rev counters,make sure that it's the right one. Don't just assume that the one in the car is the correct one either, you can't count on it.
Or you could just replace the board at the back, which takes only a couple of minutes as the rev counter itself seperates easily.

I replaced the one on my 5pot JTD with one from a 2.5V6.

olour of dials is not important as this can be changed.

look on ebay, should get one for 10-15quid.
 

·
Registered
Joined
·
1,614 Posts
Hi,

A new rev counter is needed to fix this problem. Had the same problem with mine. Make sure the garage orders you the right one form the chas. no. the first one they orded for me was for a petrol car not much good for my diesel !!! Should cost you about £150 inc VAT.

Adrian

see above, just change the back board/control unit part for the lights, the rev counter itself slides off on 4 pins.
 

·
Registered
Joined
·
1 Posts
Hi,

This seems to be the exact same problem I am having we out 156.

The rear light bulb is glowing very dimly all of the time and we have the bulb warning light on the dash.

Anything else I should check first, any wiring or other connections?

If it is the control box behind the rev counter... is it an easy job to change and what is the part name - can't seem to find any on ebay at the mo!

Cheers!

Dan
 

·
Registered
Joined
·
30,262 Posts
Also check the earthing points for the rear lights.
They are behind the carpet on the vertical part just under the lights.

If they are ok you probably are looking at the revcounter issue.
 

·
Registered
Joined
·
8 Posts
Just got same thing on my 156. Tail light glowing dim and bulb warning light on. changed bulb and everything clears until i turn lights off - then back to square 1 again. Day later engine mgmt light came on. Recently had new crank sensor following engine cut outs - could it be related or are you all going to say " change rev counter"! Is there a cheaper option than this - I'm broke!
 

·
Registered
Joined
·
30,262 Posts
... or are you all going to say " change rev counter"!
yep

Is there a cheaper option than this - I'm broke!
Doesn't have to be a new one, a correct version from a breaker will do.
Or get any 156 rev counter and desolder the faulty chip from the back of yours and replace with one from the s/h unit.
 

·
Registered
Joined
·
11 Posts
Hi Guys,

just replaced my rev counter for a second hand one. All works fine but the warning light is still coming on. I noticed that it is the light on the rev counter dash itself which is not lighting up. Rear tail light problem solved. Could I just replace the bulbs with my previous rev counter ??

Other thing I noticed is that the rev counter I have has a different symbol for the Fuel Injection which resembles a hose whilst the previous fault rev counter resembled a pipe? Is this not an issue......... ?
(Hose - symbol goes once engine has started) - Im assuming a different year of production.....mine is a 2001 156.
 
1 - 14 of 14 Posts
Top