Alfa Romeo Forum banner

1 - 6 of 6 Posts
A

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Has anybody else with a Sportwagon or 147 had a rear wiper that really does not want to get out of bed in the morning? It works, but drags itself across the screen with great reluctance.

Does a dismantle and clean up cure it or is it a new motor job..or are they all that bad :rolleyes: ? I'm going to try a clean up anyway, but just wondered if others had any experience of this.

AlfaLincs
 

·
Registered
Joined
·
33 Posts
can't believe that just washed my 147 went to wipe the rear window before chammying and it just packed up half way across??!! can still hear it clicking but no movement only motor end getting warm when i took the cover off!! time to google rear wiper me thinks!! :rolleyes:
 

·
Registered
Joined
·
33 Posts
hi, have taken wiper motor apart yesterday and there was a little rust on the cam gears, as when i bought the car the washer pipe was disconnected in the boot. (prob tried to wash in the ice!):rolleyes:
any way cleaned all crap out and sprayed with solvent cleaner and put new grease in and also opened motor and checked brushes and gave them a clean. all back together and it only works again !!!! :p
 

·
Registered
Joined
·
835 Posts
well done, the SW rear wiper is notorious for being rubbish, there's a metal drive runs on a plastic wheel and who would've thought the metal wheel chews up the plastic after time? :rolleyes:
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #5
Back when I a lad I had a Peugot 204 that had a plastic/fibre gear wheel in the wiper gear box. This wheel used to strip. Peugeot listed the wheel as a spare and said "Its a safety feature to stop you wrecking the motor if your wipers are frozen on the screen" There was sense and logic to this..except the wipers were manic and would strip said cog about once every 18months come rain or shine, so we kept a small supply of them

It was only 2 shillings and half an hour to fix when all was said and done :D

Yes I cleaned out the gearbox and regreased it on the SW, and it has made an improvement, but its still quite a weedy setup. But I broke the rear trim panel....£39...sirry irriot!:mad: :mad:

AlfaLincs
 
1 - 6 of 6 Posts
Top