Alfa Romeo Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
hi all my rear heated screen is not working, iv checked fuse ok I can hear relay click on and off when I press button inside and button does light up, with button on and lite up I checked with multimeter power to tabs on rear screen and nothing, does anybody think the switch could be faulty or possibly a break in wire from switch to window, I don't know how to get to switch to check power there.
Thank you if anyone could help.
 

·
Registered
Joined
·
21 Posts
hi all my rear heated screen is not working, iv checked fuse ok I can hear relay click on and off when I press button inside and button does light up, with button on and lite up I checked with multimeter power to tabs on rear screen and nothing, does anybody think the switch could be faulty or possibly a break in wire from switch to window, I don't know how to get to switch to check power there.
Thank you if anyone could help.
I think I would be looking at where the cable goes into the rear hatch from the car body via a rubber gromet ! I think all makes of car suffer from ware and tear hear due to the hatch opening and closing then breaking the wires
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
I think I would be looking at where the cable goes into the rear hatch from the car body via a rubber gromet ! I think all makes of car suffer from ware and tear hear due to the hatch opening and closing then breaking the wires
thanks mark i will give that a look cheers.
 

·
Registered
Joined
·
17 Posts
Discussion Starter #4
I've sorted the heated rear screen I pulled away the rubber grommet to expose wires going into tailgate, and there straight away noticed wire had completely broke in two, reconnected with bullet connectors and happy days job done, and to think that two garages didn't want to look at it and Alfa themselves said they would need it for a day to do diagnostics yay. Only cost couple of quid.??
 

·
Registered
Joined
·
4 Posts
hi all my rear heated screen is not working, iv checked fuse ok I can hear relay click on and off when I press button inside and button does light up, with button on and lite up I checked with multimeter power to tabs on rear screen and nothing, does anybody think the switch could be faulty or possibly a break in wire from switch to window, I don't know how to get to switch to check power there.
Thank you if anyone could help.
Hello londoncabby,could you indicate what the relay is and where it is located?
Do you know what is the PIN that supplies the power to theheated rear windscreen?
Thanks!
 

·
Registered
Joined
·
5,340 Posts
Unfortunately once one goes others will follow. Upgrading the wires to silicone covered type, either using a kit or from a reel is the better answer. With bit of luck your wires will be different colours, on the Giulietta all of them are black!

I've sorted the heated rear screen I pulled away the rubber grommet to expose wires going into tailgate, and there straight away noticed wire had completely broke in two, reconnected with bullet connectors and happy days job done, and to think that two garages didn't want to look at it and Alfa themselves said they would need it for a day to do diagnostics yay. Only cost couple of quid.??
 

·
Registered
Joined
·
4 Posts
Hello londoncabby,could you indicate what the relay is and where it is located?
Do you know what is the PIN that supplies the power to theheated rear windscreen?
Thanks!
Hello, I answer myself, the relay is the T19 and according to a diagram the PINs are 87, 30, 86 and 85, with the particular function of each PIN explained in the diagram.
You will wonder why I need this data? I want to connect a led to know when the DPF regeneration is being done.
I will post again if it works. Cheers
 

·
Registered
Joined
·
4 Posts
I'm sad, I connected a led to this relé, I tested with the switch and it turned on, but when I drove and regenerated DPF, the led didn't light up during said regeneration. It seems that it only works with Peugeot, Citroën, Renault, Opel...:(
 
1 - 8 of 8 Posts
Top