Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
103 Posts
Discussion Starter #1
Hey lads, whats the craic.

Ive had my alfa the last year and its pretty much been trouble free, but now ive got a problem :mad:

There was a rear brake light failure, but before i got to replace it it start saying there was left side light failure. So i went and got a new bulb.

Replaced the bulb...but now my drivers side front sidelamp stays on the whole time, as does my passsenger side rear brake light. even when the keys are out.

I went through all the fuses (actually can someone show me a fuse guide? I dont have a manual!) and the lights still stayed on. I checked the relays (the ones beside the battery) and all seem good. Could it be a problem with the earthing? Or is this a common problem?

Does it need to be hooked up a diagnostic computer to tell me what the problem is? Generally how much will the robbers at alfa charge me? Or does the AA have this same equipment

I heard it may be something with the computer? And it costs €500 euros to be repaired?? I hope not, how could the computer be affected and broke from changing a bulb? Or maybe a computer reset? How much is that? I really dont have the money for all this, so annoying

its really really annoying the hell out of me, i keep disconnecting the battery every time to stop it running down. All this after a simple bulb change!

Any ideas?

My nearest alfa daler is the one on the airton road in Tallaght...should i avoid?
 

·
Registered
Joined
·
4,646 Posts
the rear light, i suspect is the tail light, not the brake light.

sounds like your rev counter is defective & need replacing

before you can do that we need to know the following:

what year is your car?

what engine?


I have spare WHITE dial, 'red injector' type which i am willing to sell.

the 'red injector' is beside the 8 of the rev counter, your car might have a yellow engine shape
 

·
Registered
Joined
·
199 Posts
wont be the rev counter on a 147, that is only applicable on the 156. The 147 has a seperate Body Computer which can go causing random lights to stay on. Had the same problem with my drivers side rear light staying on. Had to order new Body Computer from main dealers. Take a look at previous thread i have posted on in regards to this

http://www.alfaowner.com/Forum/alfa-147-156-and-gt/140041-147-body-computer.html

Hope this helps
 
M

·
Guest
Joined
·
0 Posts
Disconnect the rear bulb holder as a wrong bulb can cause this issue failing that disconnect the battery for 10 minutes and if this is still not working sure drop me a pm as I have years of experience on these cars...
 

·
Registered
Joined
·
103 Posts
Discussion Starter #6
looks like its the body computer, looks like its a fortune to replace to.
How could this happen from simply changing a bulb?
 

·
Registered
Joined
·
3,230 Posts
Hey lads, whats the craic.

My nearest alfa daler is the one on the airton road in Tallaght...should i avoid?
WARNING WARNING AIRTON MOTORS

Useless bunch. I've been down more than once, with my 155 and my Fiat. The throttle cable went on my 155 and it was sitting in their yard for a month while they made practically no effort to source one. Kept giving me ridiculous excuses. In the end I had to source it myself from Don Baker down in Enfield. And eventually they fitted it.
 
1 - 7 of 7 Posts
Top