Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
32 Posts
Discussion Starter #1 (Edited)
I noticed this when i brought the cup but dnt think much of it & its not got any worse just annoying only happens @ low speed and usually over rough roads or bumps no sound @ all when on motorway etc its on the rear o/s exhaust exit side, had a similar noise on a cooper s turned out to be a broken exhaust bracket but not sure if this is suspension or a broken braket again. Has any1 else had this on a cup or similar. Had monza take a look when it was serviced & they said no probs with suspension only a loose bump stop.:confused:
 

·
Registered
Joined
·
32 Posts
Discussion Starter #3
Thanks mike,
recent new battery & was doing it b4 & still is so dont think so but not sure bout heat shields il put that as a maybe & get them to check that.
 

·
Registered
Joined
·
32 Posts
Discussion Starter #4
So took the cup to quick fit today, i know what ur all thinking why quick fit but i do think they are a lot better then sum people give them credit for & 2 mins down the road from me rather them 40 mins plus for monza !! anyway it seems loose heat shield & drop link are causeing the annoying rattle. Other then that they thought the underside was very good & been well loooked after. Even took me out to have a look !! Also i asked monza to have a look when it was serviced & they found nothing wrong !! A BIT WORRING FROM A SPECALIST DONT U THINK ?? all booked in for sat. Also thought i might give the underside a clean anybody got any recomendations on what to use ??
 

·
Registered
Joined
·
1,843 Posts
Personally I'd avoid jet washing it because the nice black stuff flakes off.

I go around with tin of black hammerite and paint over any spots where the original coating has come off.

Personally wouldn't worry about cleaning it per se... it will be filthy again within few weeks.

Others will have some better ideas than me, I have never cared for an aging classic
 
1 - 5 of 5 Posts
Top