Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
497 Posts
Discussion Starter #1
had a rattle for a little while i think its the crank pulley its now developed a squeak both only when cold squeak soon stops after a rev or 2, i did spill some coolant on the aux belt when topping up at night and the squeak seems to of started after that. if i take the aux belt off will the pulley still rattle/squeak even though there's no pressure on it?? which would prove or not its the pulley. or could it be the coolant residue causing the belt to slip a little?
Thanks!
 

·
Registered
Joined
·
4,772 Posts
I had a squeak from the belt that turned out to be the crank pulley which was breaking up, it was about to let go and the guys at Sunnyside recommended they keep the car overnight until a replacement was obtained. The damage these cause when they fail can be extensive, have you felt the weight?

The belt was changed also as it had been running out of line.
 

·
Registered
Joined
·
5,621 Posts
mine was done at the alfa specialist i bought it from, under warranty too so i don't know about costs, but it took no more than around 10 minutes for them to fit, on ebay they seem to be around £80-£120 ( i'm guessing cheaper ones possibly poorer quality )
 

·
Registered
Joined
·
497 Posts
Discussion Starter #9 (Edited)
had a look this morning, fairly sure its the crank pulley. had a quick go at getting the belt off but wasnt sure how to do it and couldnt be bothered to fight it, so probably be alfa shop when they open on the 3rd! lucky gits. or though i think it has been a blessing in disguise noticed the bonnet catch was quite sticky so cleaned that up :)
 

·
Registered
Joined
·
497 Posts
Discussion Starter #10
she's all sorted thanks for everyone's advice, it was the crank pulley. though when alfashop took it off it looked fine! got them to change it anyway and no more noise :thumbs:
 
1 - 10 of 10 Posts
Top