Alfa Romeo Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I have upgraded the RadioNav unit in my 2010 Brera 1750 to a Pioneer Apple Car play. I didn't realise that the column stalk menu for clock setting, lock settings etc didn't work if you have RadioNav - it is all done through the head unit. After replacing battery my clock and date settings are wrong and I cannot reset them. I also cannot alter other settings. The odometer is also blinking (a common issue I believe) and with the blinking clock its a little annoying. The new head unit is vastly superior to the RadioNav so I really don't want to swap back until I sell the car. Its been into a leading Alfa Independent Specialist who connected it up to the computer but they say they cannot alter the clock settings this way and they can't get the canbus (is that right) to recognise the unit so can't stop the odometer blinking. Guess I can live with it if I have to as there is a clock on the head unit, but it would be nice to find a fix. Any ideas?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
I will ask but I would have thought so - they did say if it was anything other than the RadioNav unit they could have probably fixed it. I don't think that would have solved the issue of how to set functions that were controlled by the head unit though.
 

·
Registered
Joined
·
38,319 Posts
Proxy alignment might force it to go back to the standard
settings control, if the control unit is fitted by default?
 

·
Registered
Joined
·
89 Posts
You did mention that you lost the setting when changing the battery so.....

What if you put the "old" RadioNav back in the car and then do the settings and when this is done replace the RadioNav for the Pioneer Apple Car play?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
You did mention that you lost the setting when changing the battery so.....

What if you put the "old" RadioNav back in the car and then do the settings and when this is done replace the RadioNav for the Pioneer Apple Car play?
could do that but I would prefer a fix that allows me to use the column stalk to change the settings. I had the new unit fitted professionally, would have to find out how to take it out, and would have to put old unit back every time the hour changed! Im thinking that there ought to be a software fix somehow - persuade the car it is a 1750 TBi with a standard radio so that the column stalk menu works instead of relying on using the Nav unit to change settings.
 

·
Registered
Joined
·
89 Posts
"Normally" to get a radiounit out must be an easy job. Most of the times you need a pair of tools (provided with the radio) to unleash it from his frame. You can unplug the connectors and plug it in the RadioNav (you don't have to put the unit back in) and do the settings (twice a year) or ..... wait for a solution (if there is) and keep looking to the blinking odometer / clock. I'll guess that when you know how to do it, you will do it within 10 minutes.
 

·
Registered
Joined
·
80 Posts
I have upgraded the RadioNav unit in my 2010 Brera 1750 to a Pioneer Apple Car play. I didn't realise that the column stalk menu for clock setting, lock settings etc didn't work if you have RadioNav - it is all done through the head unit. After replacing battery my clock and date settings are wrong and I cannot reset them. I also cannot alter other settings. The odometer is also blinking (a common issue I believe) and with the blinking clock its a little annoying. The new head unit is vastly superior to the RadioNav so I really don't want to swap back until I sell the car. Its been into a leading Alfa Independent Specialist who connected it up to the computer but they say they cannot alter the clock settings this way and they can't get the canbus (is that right) to recognise the unit so can't stop the odometer blinking. Guess I can live with it if I have to as there is a clock on the head unit, but it would be nice to find a fix. Any ideas?
Hi there,
I think you'll need Multiecuscan to do a proxy alignment.
In Multiecuscan, select "Body/CAN Setup/PROXI Alignment Process" and hit "Connect" and then "Y" when you get "WARNING"
Go to the Adjustments tab and scroll down to "Information displayed" right at the bottom of the list.
Under "Information displayed", you will probably have Type 5/RadioNav selected. Try changing this to Type 1/Blue&Me and perform a proxy alignment.
Worked for someone else with a similar issue - see thread: http://www.alfaowner.com/Forum/alfa...andquot-menuandquot-is-gone.html#post12383753
Good luck.
 

·
Registered
Joined
·
1,153 Posts
Hi there,
I think you'll need Multiecuscan to do a proxy alignment.
In Multiecuscan, select "Body/CAN Setup/PROXI Alignment Process" and hit "Connect" and then "Y" when you get "WARNING"
Go to the Adjustments tab and scroll down to "Information displayed" right at the bottom of the list.
Under "Information displayed", you will probably have Type 5/RadioNav selected. Try changing this to Type 1/Blue&Me and perform a proxy alignment.
Worked for someone else with a similar issue - see thread: http://www.alfaowner.com/Forum/alfa...andquot-menuandquot-is-gone.html#post12383753
Good luck.
Good direction. MES will do, but e.g. Alfa dealer with their Examiner probably won't (they are restricted to VIN related configurations only and can't change anything as far as I know).
Though I'm not sure if the Information Displayed should be Type1/Blue&Me or just None - either he no longer has Blue&me (e.g. demounted as new radio will do that functionality) or he never had B&M, not sure if it is possible to have 3rd party Radio and working B&M with it. Anyway, no harm to try either, maybe both will work OK, maybe one of these only.

Attached is example screenshot from MES (demo mode, just random values), may be of some help for somebody who will do it first time.
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter #10
that sounds like exactly the info I need, and at around £115 not prohibitively expensive. Have checked out the suppliers site, only issue is that Brera 1750 TBi not listed in compatible vehicles - but should be same as 159 1750 TBi I would have thought, at least for this issue. Have emailed softwire supplier to enquire. thanks for the info.
 

·
Registered
Joined
·
1,153 Posts
mes license is eur50 and bt or usb elm327 with adapter(type one, needed for some of units if you like full solution for your car) is order of EUR15. elm must not have termination resistor (order one without for fiat/alfa, or remove yourself, otherwise may not be able to communicate with car at all or reliably)
 

·
Registered
Joined
·
9 Posts
Discussion Starter #12
After enquiries to MES themselves, decided to get package with OBLlink from Gendan as this is more reliable than ELM. Upgrade to Apple Car Play Unit + speakers cost me a grand, so £115 to sort this out isn't too much! Looks hopeful!
 
1 - 12 of 12 Posts
Top