Alfa Romeo Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
Had to put in a replacement battery today in my 56 plate 159 2.4 diesel. This has now meant I need to put in the code for the radio/satnav/etc. Unfortunately, I don't have it. Any ideas?
 

·
Registered
Joined
·
75 Posts
You will need to get a removal tool x 2, they are about £3 off eBay or halfords sell them mate one in each end and then it just slides out
 

·
Registered
Joined
·
75 Posts
No probs, just don't do what I did and out the wrong code in a few times as had to leave key in ignition for 6 hours to reset after about 5 incorrect entires, lucky it didn't get nicked!
 

·
Registered
Joined
·
12,574 Posts

·
Registered
Joined
·
75 Posts
The numbers were not anywhere in my service pack aside from the incorrect radio code! I could only get the code from the unit itself
 

·
Registered
Joined
·
12,574 Posts
Garry, can't find it ....
Ok:)......sound like one of my kids:lol:

If you have to take the radio out you will need something like this.....

http://www.amazon.co.uk/gp/product/...rd_t=201&pf_rd_p=479289247&pf_rd_i=B003JIB68U

Then follow the link I posted above and Hay88 may be able to get you a code, I know the title suggests 147, 156 and GT, but others have found codes for their 159.

Oh....the most important thing...post the result of your dilemma, good bad or indifferent to help others searching for the same issue.

Good luck:thumbs:
 

·
Administrator
Alfa 159 1.9 JTDm Sportwagon
Joined
·
5,859 Posts
There must be something wrong with the unit or it has been changed as I have disconnected my battery many times and it does not ask for the code?
 

·
Registered
Joined
·
12,574 Posts
There must be something wrong with the unit or it has been changed as I have disconnected my battery many times and it does not ask for the code?
Same with mine:thumbs:

Had battery disconnected dozens of times, never had to input a code.:)
 
1 - 13 of 13 Posts
Top