Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #1
Anyone replaced the radiator cap ? I have a 07 Alfa 147 1.6 TS 88kw and i was thinking maybe i should change the radiator cap. Will check it tomorrow,an hopefully add some pictures-if i don't forget.
Anyone else done this? Where did you buy the cap from?
 

·
Registered
Joined
·
245 Posts
No cap on the radiator as far as I know. Just the cap on the coolant expansion bottle. Any good Alfa parts supplier will have them available in the UK.

What makes you think you should change the cap? Are you loosing coolant, or is temperature not quite what you expect?
 

·
Registered
Joined
·
96 Posts
Discussion Starter #3
Temperature fine,but sometimes coolant level drops.
Can't quite figure where it goes,nothing unusual in expansion bottle or under oil cap.
It seems to be forever at the same level then all of a sudden small drop about 50 ml.
Not the first car it does this,I thought could be the head gasket.
Anyone's suggestions are welcome
 

·
Registered
Joined
·
1,899 Posts
Take a close look at the rubber sealing ring inside the cap. If it looks at all pitted, lined or uneven, change it. They do deteriorate and need changing eventually, and very slight and occasional coolant loss is exactly what happens when they wear. A new cap is about a fiver.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #5
Yes,i plan to do so tomorrow,bit concerned cause someone before you said there is no radiator cap. Will have to verify myself,only too tired to go out again as the car is parked very far from home.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #6
Just been to the car,mikesalfa was spot on-no radiator cap,at least no visible one. I already ordered a new expansion bottle cap,so will be replacing that too.
After careful inspection,i noticed the rubber hose that goes to the upper part of the radiator and then to the engine appears to have crystals of antifreeze and small droplets of greasy liquid.
I suppose it is normal for a 12.5 year old car. I will consider doing a antifreeze change also,haven't done it until now.
Where can i order one from,EuroCarParts doesnt appear to have one,alfashop has one for a GTA model,would that be the same?
 

·
Registered
Joined
·
1,899 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter #8
Oh yes,definitely will change the clips too,as far as i could tell it already had jubilee clips on.
Thanks Mister !
 

·
Registered
Joined
·
245 Posts
Make sure you get good quality jubilee clamps. Stainless steel and smooth on the inside so it does not damage hose when tightening. If it's magnetic then it's not good enough.

Coolant loos could be from anything really. Hoses can leak at the clamp ends, tank cap could be damaged, coolant tank could be cracked or damaged, radiator could have a leak, waterpump leaking. The list is almost endless. I personally had a leaking water pump and a radiator hose that was not done up tight enough after I changed my coolant. That caused a small loss of coolant.
 

·
Registered
Joined
·
96 Posts
Discussion Starter #10
I believe it is near the end that goes to the engine block,I noticed crystals forming there ,right under the jubilee clamp.
Got an appointment tomorrow with a mechanic to check what else needs changing and see how much is the antifreeze change.
 
1 - 10 of 10 Posts
Top