Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3,456 Posts
Discussion Starter #1
Hi all - santa got me a DA for xmas and i finally got round to using it a couple of days ago - I'm using Meg's ultimate compound, polish and wax, my car is a 75 spider with paint that was done at least 15 years ago, its blooming so I thought i'd have a go at cutting it back. The compound works brilliantly but when i try and use the polish it "sticks" and is really difficult to buff out with DA or microfibre, even then it leaves marks; as an experiment I applied the wax on top and all the marks came off giving a brilliant finish, so the question(s) are
Why is the polish so difficult to remove? (cold dry day no direct sun)
Can I just cut and then wax and leave the polish out altogether?
Thanks
Oh yes forgot to say when applying the polish its still taking paint off
 

·
Registered
Joined
·
1,792 Posts
Not sure about the paint coming off, I guess that there is no clear coat?

It might help to use some detailing spray as a lubricant and check the speed of your polisher - might be a idea to google and check some youtube vids to see if you find the same problem you are experiencing as a way of getting some tips?

Also The Worlds Largest Resource for Detailers, Valeters and Car Cleaning

is a wealth of information
 

·
Registered
Joined
·
3,456 Posts
Discussion Starter #3
Thanks - I've trawled google for info but much of it is contradictory and everyone seems to have a different opinion, not to worry i'll just do what works and avoid the polish - no clear coat
 

·
Registered
Joined
·
202 Posts
The most obvious candidate is that it is too cold for the polish. Look at the spec sheet and see what it says about operating range.

If problems persist, try something like Detailing Kingdom 3.1 or 1.1 which have very long work times and do an excellent job, or the Koch Chemie range.

Both are superior in terms of finish (in my estimation) to the Meg's anyway, and a darn sight easier to work with.

What pad are you using?

Peter
 

·
Registered
Joined
·
3,456 Posts
Discussion Starter #6
I'm using the softest pad to apply with the DA but have also tried the Meg's hand pad, same result, I'll check the temperature but the panel was warm - not hot - to touch, going to see what happens on my moderns with clear coats - thanks
 

·
Registered
Joined
·
988 Posts
1 - 7 of 7 Posts
Top