Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
301 Posts
Discussion Starter #1
Hi all I have a 159 2.2 2006 and I come to it tuesday morning put the key in waited for dash lights to clear and hit the start button and just a click from the relay no start or clicking starter motor and kept pushing key out slightly...

Got my mechanic round last night and he tested for power to starter when button start was pressed and there was 12v to the solinoid so he has replaced starter tonight as the one that was on was original and still the same thing just clicking relay as normal but nothing at all from the starter.

The car bump starts fine with no warning lights on the dash board any ideas guys.... only warning light is for brakes worn out but new discs and pads fitted 2 weeks ago pad sensor must not be compatible. thanks a lot:confused:
 

·
Registered
Joined
·
301 Posts
Discussion Starter #3
Yeh I thought that so we tried to jump start off another car but still no joy from the starter unless it has an anti jump start system to stop overload ??
 

·
Registered
Joined
·
1,589 Posts
try rocking her back and forward a bit to see if the starter has stuck or jammed, might free it up.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #5
Hi tried that thinking starter was jammed but no joy..... well had new starter as it had original one on and new battery as it tested to be broke and was still the same...

Mechanic has just had it up on the ramps and there was an earth wire to the gearbox that had snapped replaced with a much better wire and hey presto all ok now..... thanks for help .
 

·
Registered
Joined
·
301 Posts
Discussion Starter #6
Just an update guys the car has never been so much better starts instantly unlike before slow turning over a much improved starter that is geared faster and a fresh battery makes all the difference :)
 
1 - 6 of 6 Posts
Top