Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all! I've had my Giulietta in for a diagnostic check as my engine management light keeps coming on and doesn't let me use any DNA function or start and stop. Also it really struggles power wise, shakes and coughs and splutters. Please could someone give me any advise on what the problem could be or if someone has had the same problem? The error code came up as 1064h/4196 if anyone knows what that could be? Thanks all!!
 

·
Registered
Joined
·
3,255 Posts
Any car details??? year?? engine??... Where did you get the codes read? Code doesnt look like an usual fault code.
 

·
Registered
Joined
·
38,703 Posts
Indeed, fault codes usually start P0****

Without a proper code it is just guesswork.
 

·
Registered
Joined
·
36,851 Posts
DNA function is blocked with any issue that illuminates Engine Management light , apparently. So no clue there.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
The car details is a 2010 1.4 multi air 170 veloce. Is this maybe a common fault or something? I may have to get it plugged in again then and repost my results. Thanks all for the advise ??
 

·
Registered
Joined
·
38,703 Posts
The car details is a 2010 1.4 multi air 170 veloce. Is this maybe a common fault or something? I may have to get it plugged in again then and repost my results. Thanks all for the advise ??
They do occasionally get a fault but it isn't that common.

You can buy code readers from ebay for under £10 and read the codes yourself.
 
1 - 7 of 7 Posts
Top