Alfa Romeo Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
25,673 Posts
Discussion Starter #1
Recently my drivers door Window Switch has started playing up, specifically the Passenger Window.

It started happening one day and the wench had to keep her finger on the passenger one to keep the window in the closed position. I could here the switch relay going like a metalist and it was beeping as well whilst she did this.

That seems to have stopped but now whenever I turn the ignition to off the passenger window opens, I have to reach across and use the passnger window switch to close it.

Sometimes I have to engage the alarm and then switch it off to stop the drivers switch engaging (no idea why this works but it does) but then sometimes that doesn't work and I ahve to sit there and hold the passenger button til the drivers one stops playing up.

My questions are.

1. What the **** is going on?
2. Can I fix this easily myself?
3. Is it just the Switch or could it be related to the Body Computer?
4. If I can't fix this myself who should I take it to? An Auto Electrician or a Alfa Indie?

Ta muchly for any insights.

Sean
 

·
Registered
Joined
·
2,140 Posts
mine has **** connections and plays up. ive now pulled it out of the slot slightly and thats "cured" it lol. My issues though were more it didn't work at all but it isn't unreasonable that if it has a dodgy connection it would behave this way.
 

·
Premium Member
Joined
·
7,799 Posts
You could disconnect the button panel on the drivers-side (very easy to do), and see if that solves the problem.... If it does, that would seem to point to a defect in this module.
Other thing to try is reset the bodycomputer by disconnecting one of the battery connections for 15 minutes or so as the windows are controlled via the bodycomputer...
 

·
Registered
Joined
·
25,673 Posts
Discussion Starter #5
Cheers for the responses. What's the correct procedure for the body computer reset and will I need to re enter my head unit code after?
 

·
Premium Member
Joined
·
7,799 Posts
Cheers for the responses. What's the correct procedure for the body computer reset and will I need to re enter my head unit code after?
Body computer reset is easy, just disconnect one of the battery connections (ground side is of course easiest). Leave disconnected for 15 minutes or so for power to dissipate

Then Reconnect battery. That's it

(you can speed the process up a bit by shorting plus side to ground (after disconnecting the battery of course ! )

Head unit code is not required, as that only needs to be done in case either the HU or the body computer is exchanged for a new unit.
 

·
Registered
Joined
·
25,673 Posts
Discussion Starter #7
Hi jwq, done a body computer reset and it didn't resolve the problem, how do I go about disconnecting the switch?

Cheers

Sean
 

·
Premium Member
Joined
·
7,799 Posts
Hi jwq, done a body computer reset and it didn't resolve the problem, how do I go about disconnecting the switch?

Cheers

Sean
Also fairly easy, if you look at the underside of the switch/door driverside, you'll see a single screw. undo that, and you can simply pull up the whole switchpanel.
After that, it's just a matter of disconnecting the plugs....
 

·
Registered
Joined
·
25,673 Posts
Discussion Starter #9
Also fairly easy, if you look at the underside of the switch/door driverside, you'll see a single screw. undo that, and you can simply pull up the whole switchpanel.
After that, it's just a matter of disconnecting the plugs....
You mean I have to take the door panel off to get at it?
 

·
Premium Member
Joined
·
7,799 Posts
You mean I have to take the door panel off to get at it?
Nope, if you look at the underside of the doorhandel, at the place where the switchpanel is located, you will see a single screw. Just undo that. After that, you can just pull the switchpanel straight up and out ....
 

·
Registered
Joined
·
25,673 Posts
Discussion Starter #11
I downloaded elearn I think I found the bit that I need its just a small screw in the side of the door panel never even knew it was there to be honest.
 

·
Registered
Joined
·
25,673 Posts
Discussion Starter #13
I've got it out and it's no longer doing what it was doing so looks like it's the switch I had it in bits but it doesn;t look like there's been any water ingress or anything, I know Dan was breaking a GTA so i'll have to see if he still has the module from that car.

Thanks for all the help :)
 

·
Premium Member
Joined
·
7,799 Posts
I've got it out and it's no longer doing what it was doing so looks like it's the switch I had it in bits but it doesn;t look like there's been any water ingress or anything, I know Dan was breaking a GTA so i'll have to see if he still has the module from that car.

Thanks for all the help :)
At least in the meantime your windows stay closed... ;)
 

·
Vendor
Joined
·
46,591 Posts
You should be able to use any 3-door 147 window switch.

Its not very clear from reading the thread, have you disconnected the driver's side switch, or the passenger side switch?
 

·
Premium Member
Joined
·
7,799 Posts
You should be able to use any 3-door 147 window switch.

Its not very clear from reading the thread, have you disconnected the driver's side switch, or the passenger side switch?
Driver's side, that's the only one with a screw :p
 

·
Registered
Joined
·
25,673 Posts
Discussion Starter #18
Foundout that for some bizarre reason because I have taken the window controls out I can no longer open my boot, it's completely dead, I wonder what else no longer works properly.
 

·
AO Car Of The Year Winner 2015
Joined
·
3,202 Posts
Foundout that for some bizarre reason because I have taken the window controls out I can no longer open my boot, it's completely dead, I wonder what else no longer works properly.
Its maybe different LHD and RHD, but on LHD if you take the window controls out, you loose outside temperature sensor which is in the left mirror what meat for me that the A/C stopped working as well. I dont remember if central locking worked or no....
 

·
Registered
Joined
·
25,673 Posts
Discussion Starter #20
I've put it back in, too much stuff relies on it i'll have to livwe with it until I can buy another £115 ex vat from alfa :(
 
1 - 20 of 20 Posts
Top