Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
I have a Mito 1.4 Multiair 2012 and as I pulled into the car park at work this morning the "Warning check power steering" text flashed up and the steering became ridiculously heavy. There has been no knocking, banging or any steering issues leading up to this. I only do 8 miles to work and back each day so the car doesn't get much of a run. I have done a bit of research and a low battery can also cause this. It still has the original battery so I'm going to try this first. My question is what battery does everyone recommend? It has the stop start feature so it needs to be able to cope with this.
Thanks.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #2
Managed to do a proper search during my lunch break and found a post which contained a link to battery info and selection.
I have just ordered a Lucas Fusion LF027 AGM from Tanya. Hopefully once this is fitted I wont have the problem again.
 

·
Registered
Joined
·
1,011 Posts
Mine did the same, got a new yuasa battery and it sorted the problem, I was only doing low miles until my work relocated so it doesn't look like it will return :rotate:
 

·
Registered
Joined
·
11 Posts
Discussion Starter #5
Yep. Thats the guide I found that helped me choose a new battery.
I fitted it last night and all was good this morning. Hopefully its sorted.
BTW: Tanya were the best price. I ordered Tuesday afternoon and it was here Wednesday morning. :thumbu p:
 

·
Registered
Joined
·
300 Posts
I've had that problem come up intermittently. Last time it was when I did a quick test drive without tightening the battery terminals. As I turned into my house the battery shifted and the terminals slipped a bit. Instantly got steering corrector problem. Was expecting it to happen. Haven't had any problems after properly fastening the battery. The battery has been on a charger/tender for the duration of my mini restoration.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #7
It seems that a low/old battery can cause a lot of different problems. My old battery charged up ok and held that charge till the following day but I wasn't willing to wait and risk seeing if it happened again. The battery was 7 years old so was due for replacing anyway. Hopefully sorted this problem and helped prevent any other future battery related ones.
 
1 - 7 of 7 Posts
Top