Alfa Romeo Forum banner
1 - 5 of 5 Posts
G

·
Discussion Starter · #1 ·
Hi Guys

Result from the recent rolling road session showed my V6 is running lean STILL!!! Its had a new oxygen sensor recently, the techs at John Nobles said it is lean all throught the rev range and suggested installing a power boost valve, cost about £70 gbp for the part.

Anyone know about these things and if there is anything else that could be wrong. Think Jimybob said the temp sensor may be at fault but not got round to that yet.

wrinx
 
G

·
Discussion Starter · #2 ·
Hey Wrinx!

& here was me putting too much petrol in! :) the powerboost valve just up's the pressure on the fuel rail by limiting the fuel return. Can't see much can go wrong with it & people seem to have no complaints. If everything else checks out ok, go for it!
 
G

·
Discussion Starter · #3 ·
A Power boost valve is usually the way to go if your car is running lean. A lot of manufacturers claim 1.7 times faster acceleration as the fuel is (variably) pushed faster into the engine.

The idea is that your standard valve will send fuel into the engine at a standard rate, regardless of whether if you are booting the car (high revs) or not.

But the PBV will send the fuel at a variable rate.I.e. the more you boot it, the more fuel is delivered more quickly into your engine = faster acceleration.

But sometimes these things lead to engines running too rich, so be careful in regards to installation/tunning etc.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top