Alfa Romeo Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
is there anyone in the Portsmouth or Southampton area that can help me. I have a 147 T Spark lusso thats just had a cambelt go and has been replaced along with 12 valves and a new camsensor fitted. Since then i can only get a max of 3k revs and a top speed of 60mph . Does anyone know what the problem could be as its driving me mad. I also get motor control system failure showing.
 

·
Registered
Joined
·
30,018 Posts
I have a feeling, that when this has come up before, it has been a cam-sensor problem.
However, I've had a busy few weeks and need more sleep... so could be wrong!
 
0

·
Guest
Joined
·
0 Posts
Was it an Alfa specialist who changed the belt using the correct tools or was it a back street 'tippex' job?
 

·
Registered
Joined
·
6,274 Posts
Cam sensor would be my suggestion as well. Snag is, it's at the back of the cam belts that you've just had fitted :(

My suspicion would be that the exhaust cam sprocket's sensor ring has been bent out of shape during the work that was done, and it's destroyed the sensor itself.

An independent inspection might be in order, prior to giving the people who did it a rollocking!

...or it may just be that the timing's out...
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
it was a back street tippex job who was recomemded to me by an uncle i have also been told that it may be the air flow sensor ??
 

·
Registered
Joined
·
30,018 Posts
Maybe the cambelt slipped because it wasn't tensioned properly.
There is also the likelyhood of the cam sensor getting damaged from the wrong tools being used.
 

·
Registered
Joined
·
1,219 Posts
you can rule out air mass by unplugging it and driving it if it drives ok then you have diagnosed it yourself. but as mentioned above if the timing is out you could destroy all again
catch 22
 

·
Banned
Joined
·
9,721 Posts
I'm affraid that due to work commitments and other things atm I wouldn't be able to get to Soton, but if you could limp it up to me then I could plug it in and certainly set the timing correctly for you.
 

·
Registered
Joined
·
4,646 Posts
maf?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #18
I'm affraid that due to work commitments and other things atm I wouldn't be able to get to Soton, but if you could limp it up to me then I could plug it in and certainly set the timing correctly for you.
That would be great where abouts are you is it far to limp!
 

·
Banned
Joined
·
9,721 Posts
timing, belt tension slipped belt, or mashed cam position sensor...i my untrained opinion...
saying that hope it is maf, easy fix...
Those are worst case, but if thetiming is out then it will be limiting, if i was MAF then there would be a rough idle too, but when he gets here we'll see.
 
1 - 20 of 20 Posts
Top