Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
Hey guys, this is my second post about this question since no one replied to my first one. Any ideas about the following annoying noises?

The first weird thing is that if you turn the ignition on, or have your engine running you can hear a ticking under the dash, seems like it's right behind the speedometer or somewhere around that area. The ticking isn't loud mind you, it ticks mostly with each second, like a clock ticks, but sometimes it stops for a while, or ticks twice a second. As i said it's quite minor but i don't want any problems brewing under that dash, so if anyone might know what it might be, i'll be very happy to listen.

The second thing that is quite annoying if you like your car to sound good, is a semi loud vibration somewhere under the engine. It sounds like there is a thin penny washer that's loose and it vibrates when the engine is revving on exactly 2000rpm. It doesn't matter if the engine is cold or hot, as soon as the rev counter reaches 2000rpm, you hear the mysterious object vibrating to the frequency of the engine. I know you guys might not know what it is but if there are any known issues with this i'm sure you will. The sound comes from somewhere under the engine and is heard the loudest from under the front right wheel arch. I will buy some locking jacks to lift the car up so i can take a proper look under neat but at the moment i'm without a job.
 

·
Registered
Joined
·
2,519 Posts
for the rattle under the engine, check the Catalytic converter front bracket/clamp. Mine was merely loose and rattled.

Could also be the manifold bracket. They often rust and crack. The two halves then vibrate against each other.


Not sure on the ticking.
 

·
Registered
Joined
·
20 Posts
The ticking dash eh,my 146 does that,one day i will pull it apart, but its never caused any problem.As for the rattle, hard to tell without sticking a head under the bonnet and listening to try and locate where the noise is coming from,
 

·
Registered
Joined
·
1 Posts
my 156 sometimes does this

the ticking noise behind the speedo on my 156 usually happens after i've had the wipers on, took me a day or two to work out is was the relay not disengaging properly, all i had to do was turn the wipers on and off until it went away.
might not be the same as your problem
hope this helps
 

·
Registered
Joined
·
132 Posts
I'm sorry for my english, but the second sound you mentioned, I have the same problem with my 147, only that it starts vibrating at 3000 rpm. They told me it's the metal cover of the exhaust on the front side of the engine. I don't know if it's the same sound, but it sounds like penny on a vibrating, very thin, metal plate.
 

·
Premium Member
Joined
·
621 Posts
could be excess mesh inside the flexi pipe, its a common thing on 147's could be the same on the 156, also check the bracket that holds the down pipes, its a little awkward to get to, but gave a metalic noise because it had cracked.
 

·
Registered
Joined
·
179 Posts
hi, your second problem sounds like a noise i had once, it turned out to be a noisy idler on the belts, it only cost £50 fitted. If i were you i would get it looked at asap, you don't want it turning into a bigger job than what it should be
 
1 - 7 of 7 Posts
Top