Alfa Romeo Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
237 Posts
Discussion Starter #1
Hi!

I own a 159, 2010 model with the original Satnav HU. (Magneti Marelli). AVH-X5800DAB | Pioneer

So I went an bought myself a Pioneer AVH-X5800DAB together with:
Connects 2 Alfa 159/Brera Canbus steering wheel interface. Connects2 Ltd
Connect 2 CTMultilead.2 Universal Patch lead. Connects2 Ltd

I have fitted the cage and the facia fits perfect, I have fitted cables for telephone mic, DAB arial and backup camera, but I can't figure out how to connect the connectors from the Pioneer to the 159 OEM Cables, they just dont match!

At the moment I regret not getting the radio shop to do the install....

What have I done wrong?
Please HELP!

Frank
 

·
Registered
Joined
·
542 Posts
I have fitted mine using those leads, they definitely fit. There should be the changer/bose cables(fits to the widest part of the connects 2 cable) and its 3 small block connectors that fit together as one. The speaker plug should fit the middle then the power part on the one that is left. You have to make sure the plugs line up when pushing them in. The patchlead follow the instructions for the pioneer layout. Mine is a Kenwood. You are left with a white plug that looks nothing like any of the others, as far as I can tell this connects to the buttons near the mirror and is now not used. If your still struggling take some pictures and post them here.
 

·
Registered
Joined
·
237 Posts
Discussion Starter #3
I have fitted mine using those leads, they definitely fit. There should be the changer/bose cables(fits to the widest part of the connects 2 cable) and its 3 small block connectors that fit together as one. The speaker plug should fit the middle then the power part on the one that is left. You have to make sure the plugs line up when pushing them in. The patchlead follow the instructions for the pioneer layout. Mine is a Kenwood. You are left with a white plug that looks nothing like any of the others, as far as I can tell this connects to the buttons near the mirror and is now not used. If your still struggling take some pictures and post them here.
Hi A_Venables! Thanks for your reply. I have taken another look at the connectors, but I am still unsure about what to do. It looks like it is possible to pry the "box" they are sitting in out of the old connector. Do they go in the middle of the connects 2? It is possible to remove the blue pin in the middle.
The two rows with yellow and black looks like they are a port of the old plug from the car...
A bit confused. Adding some pictures:)

So glad for any help i can get:)

Frank
 

Attachments

·
Registered
Joined
·
542 Posts
Picture shows old plug and new plug!
Your right, those aren't the same, I'm sure the one on your car is called a Fakra plug, its not the same as on mine! My Corsa had that setup. Think your going to have to see a car radio shop for this, the sites I'm clicking on only show the connects 2 adapter you and I have to fit your car, which obviously isn't what your car has! I wouldn't start altering the original plug as you never know if you might want to fit the old head unit back in again! Try to get the correct adapter. It maybe worth sending connects 2 the pictures and ask what to do?
 

·
Registered
Joined
·
237 Posts
Discussion Starter #6
Your right, those aren't the same, I'm sure the one on your car is called a Fakra plug, its not the same as on mine! My Corsa had that setup. Think your going to have to see a car radio shop for this, the sites I'm clicking on only show the connects 2 adapter you and I have to fit your car, which obviously isn't what your car has! I wouldn't start altering the original plug as you never know if you might want to fit the old head unit back in again! Try to get the correct adapter. It maybe worth sending connects 2 the pictures and ask what to do?
Thanks again, I have sent pictures to connects2 support, and I will post the solution to this problem on this page so if someone else encounter this problem they will know what to do:)
 

·
Registered
Joined
·
4 Posts
Thanks again, I have sent pictures to connects2 support, and I will post the solution to this problem on this page so if someone else encounter this problem they will know what to do:)
FrankieNorway: Did you find a solution to your connector problem? I am facing the same issue as you. The car, 159 TI 2010, also have the Fakra quad connector which doesn't fit the connects2 interface. Tempted to ask a car stereo dealer to do the job..
 

·
Registered
Joined
·
11 Posts
Hello, some solution to this problem?.

I have this gps now, and I want to change for one Pioneer AVIC. No idea how start.

 

·
Registered
Joined
·
31 Posts
Not anything? I have gbot the same problem 159 TI SW 12/2011. I can't be that difficult? I mean actually it's like 4 wires that needs to be connected properly - the rest is ISO standard?
 

·
Registered
Joined
·
11 Posts
I have installed finally my Pioneer 2DIN.

I use a Quadlock for Citroen adaptor with the Connects 2 Uni-3... welded some cables, and wuala!!!

Next month I will make a post with photos.
 

·
Registered
Joined
·
31 Posts
I have installed finally my Pioneer 2DIN.

I use a Quadlock for Citroen adaptor with the Connects 2 Uni-3... welded some cables, and wuala!!!

Next month I will make a post with photos.
Next month? :vs_sad:

I already stripped my car for the old unit, not being able to put it back in.
 

·
Registered
Joined
·
11 Posts
First, I needed do a Proxy Alingment after remove the original gps radio and the blue and me module.

Second, this is what I installed:
- Connects2 Ltd
- Connects2 Ltd
- https://catalog.autoleads.co.uk/catalog/steering-wheel-control-adaptors-cp2/cp2-psa52 (I used only the cable, because the interface stop working after 2 weeks)

I welded the UNI-SWC.3 with the cable of CP2-PSA52, and works!!!

In my case, I have Bose system, and I needed also weld the pre-out cables of my Pioneer to speakers of the quadlock conector, and the blue cable for the amplifier.
 

·
Registered
Joined
·
16 Posts
Quimi

Short question.
After doing Proxi alignment, are you able to set the clock with the last hand steering wheel stick?
Normally this is done on the original head unit but that was removed.

Thx!!
 

·
Registered
Joined
·
31 Posts
Yes, it works like if you had the "normal" radio installed.

Quimi

Short question.
After doing Proxi alignment, are you able to set the clock with the last hand steering wheel stick?
Normally this is done on the original head unit but that was removed.

Thx!!
 

·
Registered
Joined
·
16 Posts
Thx!

2 more questions
Did you reuse the mic of the car or install the one that comes with the head unit?
What about the antenna? Connected the original to the head unit? If so, how?
 
1 - 16 of 16 Posts
Top