Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1,843 Posts
Discussion Starter #1 (Edited)
Hi, sorry to make another thread but I didn't want to hijack the old one someone else just asked for help on.

That thread got me thinking "I've never heard my fan come on, ever... :rolleyes:" and indeed never seen it come on when I've had the bonnet up and engine running. But the temperature *never* goes above the 90 mark, and I've been running her for 6 months, often in lots of traffic, with no apparent harm done (I hope).

Although the coolant is very black. History says thermostat replaced in 2009. No loss of coolant over the 6 months. Coolant return pipe appears to heat up with the engine rather than rush with heat suddenly. It is also chomping through fuel... never got above 28mpg on petrol...

Is it possible my temperature sensor is reading wrongly?

Is my thermostat stuck open (I like this explaination if it means my engine hasn't been cooking itself)

Can you hear the fan from inside the car? And should I have noticed it by now?

Why hasn't my engine siezed up and died?
 

·
Registered
Joined
·
2,959 Posts
on mine you would deffinatly be able to hear the fans although only when stationary
 

·
Registered
Joined
·
447 Posts
After changing my thermostat, first time the fans came on I thought the car had turned into a hovercraft. You can definately hear them.

New thermostat for mine was £52 from autolusso (alloy top one with two way pipe at the bottom is more expensive :( ) doddle to fit, took a while to get all the clamps undone, (2 hours near enough) then 20 minutes to fit the new one.
 

·
Registered
Joined
·
447 Posts
I just went to autolusso (they are like 5 miles down the road from me!) This one was a 'Facet' - 'Made in Italy' :)

Make sure you get the right one there are a couple of different ones.
 
1 - 6 of 6 Posts
Top