Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
98 Posts
Discussion Starter #1
hi,
my parking brake is not working like it should
rear right(normal)brake only working at 60%
what can i check?
thanks
V6Tb
 

·
Registered
Joined
·
139 Posts
Hi Md11,

Does only the handbrake give the 60%, or also when normally applied with all brakes?

I would first check the simple things:
- pads, are they within spec or glazed
- does the caliper slide as it should, without pads you should be able to slide it sideways easily
- does the 'pad-wear compensator' work; that's rotating bit on the piston, maybe it's turned itself fully outwards and cannot compensate for padware anymore??

Otherwise you'll get to the more difiicult stuff:
- caliper's own hydraulics (overhaul)
- brake pressure limiter on pre-2001 models (on LHS of the car, near the rear axle)
- ABS system.

Cheers
Martijn
 

·
Registered
Joined
·
98 Posts
Discussion Starter #3
handbrake 60/70 % both wheels
brake rear right 60/70 %
brakepads ok
fluid ok
 

·
Registered
Joined
·
139 Posts
Hmm, intersting :p

As with both tests you have less brake-power, you would think it is something the hand/parkingbrake (cable operated) and the footbrake (hydraulic) share. The pad wear compensation might be able to influence both 'systems', although the BRR is the odd one out when braking normally. Could be a slightly sticking piston or some air trapped in that brakeline.

What you can check, or re-do, is the hand/parkingbrake adjustment. Take all rear pads off, twist the piston fully back into the caliper; the piston twists outwards to compensate pad wear, hence you'll have to turn it back.

Slacken the hand/parkingbrake cable fully (adjustment nut under the lever itself), even remove the cables from the caliper and then according to the service manual; 'operate the brake pedal forcefully at least ten times'. That probably will re-set the pistons so they take up any slack between piston and pad.
Reconnect cables, set the hand/parkingbrake lever in the third notch and tighten the cable until the wheels are braked.

With my dad's 156 the 'Alfa specialist' (official dealer :rant: ) tried adjusting the hand/parkingbrake without letting the piston twist the slack away; they fully tightened the hand/parkingbrake cable to get the slack out, as a result you needed arms like the Hulk to pull the hand/parkingbrake lever up 3 notches -and the thing still wouldn't apply the brakes!
On the calipers you could see the hand/parking brake cable lever was tightened fully, it could only move marginally until it could not move at all -hence you couldn't get the lever up more than 3 notches.

Did above adjustment, now it works fine -so that might be an easy thing to check on your TB. It would also 'jog' the BRR's piston a bit.

Cheers :thumbs:
 
1 - 5 of 5 Posts
Top