Alfa Romeo Forum banner

1 - 6 of 6 Posts
D

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
I've bought a small diagnosis tool which comes up with the code P0203 Ignition circuit open cylinder 3 on a Diesel 156 so I know it's impossible to say but am i looking at wiring of injector itself ? It's running like a bag of spanners though i have no excessive black smoke out the back and i think it gets a little better when warm .
 

·
Registered
Joined
·
12,574 Posts
Sounds like the common injector wiring issue.

Have you done a search on the forum?

There are loads of threads about this.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #4 (Edited)
Oh you star thank you, by the way It all helps :thumbup:
I have previously checked the connections looking for dirt and blackened connection but all seemed well though I'll have another look tomorrow but while we're all here can you nswer this , after ive checked the wiring i was going to swap injector 3 and 1 around then check the code again but are the injectors coded to the ecu their particular places ? and If it turns out to be a knackered injector can i just buy a 2nd hand and replace ?
 

·
Registered
Joined
·
2,271 Posts
It's not easy removing injectors (not like a spark plug) so I don't think it's an easy way to diagnose if you have a faulty injector. As you elude to in your post the injectors can't be swapped willy-nilly.
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Fiddled with the connection on injector 3 and it's running like a dream , so i've cleaned, sprayed contact stuff and ty rapped to hold it for now but ive read that there's a repair kit for it somewhere .. (?) ... Anyway it's running ..
Sincerely Many thanks for the help, so bloody annoying a simple thing can cause such annoyance.
Again Thank you.
 
1 - 6 of 6 Posts
Top