Alfa Romeo Forum banner

1 - 20 of 21 Posts
H

·
Guest
Joined
·
0 Posts
Discussion Starter #1
http://www.alfa155.com/forum/ubb/icons/icon14.gif
HELLO THERE, can some one help me please?? got this v6 which wasnt in use for months when i bought it. the air con fan went on & off a few times before it died when i was driving it home. i also discovered that the cooling fan isnt working hence overheating occurs. there's also a red warning light on with a symbol like a battery next to the frontlight symbol. this warning light only comes on after switch on the lights, whats happenning?http://www.alfa155.com/forum/ubb/icons/icon5.gif
 

·
Registered
Joined
·
4,651 Posts
Henry

Firstly you need to use
at the begginning and end of you smilies to get em to work :D

Re garding the overheating you need to see if its the fan or the power supply at fault

Easiest way is to pull the connector off the radiator fan switch and join the connectors together with a bit of wire switch ignition on and see if the fan runs

Also i think there is a fuse in the secondary fuse box under the dasch which could of gone

Re the air con fan :rolleyes: i have`nt got a clue as my V6 does`nt have power sapping air con :p :p :D

Hope all this helps if not someone else will have some better suggestions :rolleyes:

Btw the warning light might be the charge light and if it comes on with the lights then the alternator might need repairing
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Hi Henry

The "battery" light may go away with use but its probably the alternator not giving out enough charge.

Overheating - check the fuses, there is one in the fuse/relay box on the front slam panel. Its a funny fuse, just a piece of metal cut to shape. There are others but I'd have to check the handbook.

Aircon fan, there is a cut out for the compressor when there's no gas and also fuses for it.

Do you have a handbook, they are all listed in there.

wrinx
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #4
The battery light comes on if there's not enough juice being generated by the Alternator but it may also come on if there's too much.

If your car gets through batteries (they go "flat" but don't recover if you recharge them) then your regulator isn't doing it's thing. You can get new regulators as a spare part but you probably need to go to an Alfa dealer where you know the parts man is on the ball.

If the battery goes flat but WILL recharge, then the alternator isn't making enough juice. That might be an alternator problem (damaged windings) or more likely just be dirty/worn brushes. Again, an auto-electrician should be able to sort it.

As Wrinkle says, dirty brushes sometimes clean themselves up with use (esp. if they've been inactive for a while) so that light may go away all by itself.

Ralf S.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #5
I forgot to say - the cooling fan not working is probably due to corroded connectors at the switch (on the radiator) as it is brass and sits out there in the way of all the salt and spray thrown up from the road.

I'd check that before ripping out all your dashboard. If the switch is so corroded/stuck in there that you can't get it out without wrecking the radiator (the radiator casing deforms under the pressure needed to unscrew the switch housing) then connect the two wires via a switch in the cab, so you can manually activate the fan when you get in traffic.

It's a bit of a bodge but it will keep you cool until you sort out the necessary new bits.

Ralf S.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Finally, don't let your lad overheat as you have there probably one of the finest engines under the sun.

It's lovingly crafted from aluminium so is more vulnerable to warping its heads if it gets too hot han the cast iron lumps favoured by some of the Philistines on this site (the 4-pot boys). wink

Ralf S.
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Ralf S.:
It's lovingly crafted from aluminium so is more vulnerable to warping its heads if it gets too hot han the cast iron lumps favoured by some of the Philistines on this site (the 4-pot boys). wink

Ralf S.
Ah but Ralf you're not entirely correct. The 8v engine is all alluminium too.

Marlon
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #8
My engine is aluminium?
For some reason that makes the car seem a tad more pleasureable to own :)
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #9
Guys,
Is this so called "battery" like warning light on the check control panel located just above the ashtray? If so, there is nothing to worry about as it is merely telling you that one of the little bulbs that illuminates the rear number plate is burnt out!

Taz.
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #10
imghttp://www.alfa155.com/forum/ubb/icons/icon7.gif hi guys thanks for the tips, the battery like light is actually the one on the check box above the ashtray. i will change the bulb tomorrow morning. i will also attempt to disconnect the fan and join it manually. i guess by now you have figured that i dont have a manual. but why is it that the fan warning light on the check box is not on. i thought it would be on because the fan isnt working??? does this suggest that it might be a blown fuse or relay??. you guys are so helpful thanks again./http://www.alfa155.com/forum/ubb/icons/icon12.gifimg
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #11
Henry,
the light you are referring to only comes on when the coolant level in the system is low.

Don't worry about it, the knowledge on this site is quite good and everyone is keen on helping so you're covered better than with "More Than"!

Taz.
 
W

·
Guest
Joined
·
0 Posts
Discussion Starter #12
Henry, I posted some pictures of the warning lights for someone else just last week I think....will go have a look wink

wrinx
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #14
just had a look at those signs WRINX,
and thanx TAZ for the info i'll make sure that i change my cover from MORE THAN to ALFA155 FORUM.
"]http://www.alfa155.com/forum/ubb/icons/icon14.gif[/img][/url]
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #16
speed freak:
Henry

Firstly you need to use
at the begginning and end of you smilies to get em to work :D

Re garding the overheating you need to see if its the fan or the power supply at fault

Easiest way is to pull the connector off the radiator fan switch and join the connectors together with a bit of wire switch ignition on and see if the fan runs

Also i think there is a fuse in the secondary fuse box under the dasch which could of gone

Re the air con fan :rolleyes: i have`nt got a clue as my V6 does`nt have power sapping air con :p :p :D

Hope all this helps if not someone else will have some better suggestions :rolleyes:

Btw the warning light might be the charge light and if it comes on with the lights then the alternator might need repairing
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #18
hi guys javascript:void(0) i have had no luck in my efforts to connect the two wires of the radiator. i maybe doing it wrong i disconnected the wires branching into the fan & joined them with a wire & connected it back. the fan didnt come on. i couldnt get under the car to look at the other wires, is that where the radiator switch is? javascript:void(0) . again that number plate warning light is still on but all the lights are working. (maybe faulty sensor).
one more thing does anybody know which fuse is for the boot coz my boot doesnt open using the button. help. javascript:void(0)
 

·
Registered
Joined
·
117 Posts
Henry...

try giving the little rubber sock that carries the wiring from the body to the boot a wiggle...

you might find it starts working again. The bending as the boot gets open can cause broken wires..got to be worth a try?

Cheers

Dunc
 
H

·
Guest
Joined
·
0 Posts
Discussion Starter #20
dunc:
Henry...

try giving the little rubber sock that carries the wiring from the body to the boot a wiggle...

you might find it starts working again. The bending as the boot gets open can cause broken wires..got to be worth a try?

Cheers


Dunc
cheers DUNC will try that in the morning, i made a mistake before WRINX but have sent the proper post.
 
1 - 20 of 21 Posts
Top