Alfa Romeo Forum banner

1 - 20 of 35 Posts

·
Registered
Joined
·
2,575 Posts
Discussion Starter #1 (Edited)
I searched and found a few related posts but none with exactly the problem I was facing... external air temperature had been reading a bit higher every day. I know it’s Spring here but this was ridiculous - 34 one day, 43 the next, 51, and then finally over 60 degrees (C) as you see in photo 1. The problem with this is that the ventilation system becomes reluctant to admit outside air into the passenger compartment. Plus, on cold mornings (when it’s actually 8 degrees C) the system gets confused by the erroneous 26 degree reading and gives a blast of cold air, when warm would be nice.

I first tried cleaning the doorframe plug, reasoning that the temp sensor signals from the mirror would pass through there. I pulled off the tweeter cover and unplugged the mirror - reading was ‘- - -‘. I removed the mirror glass by tilting it in and down, then used a long thin screwdriver to release two of the clips. Then I discovered that the temp sensor has been living underwater (photo 2). It’s also pretty funny that the mirror motor writing begins “VW AG”.

I identified the temp sensor wires in the mirror plug and measured a resistance of 2.2k ohms - not a short circuit or open circuit by any means. Perhaps it was working correctly and there was a short somewhere else, or perhaps the body computer was faulty? I used a resistance substitution wheel (could use just a resistor) to substitute a 10k ohm resistance (in place of the sensor) and got a reading of 25 degrees C. This seemed to suggest that the body computer and wiring was fine, and that the sensor was somehow reading too low (i.e. a connection that was “too good”; hard to imagine!) :lol:

At this point I considered getting the car fixed under warranty, but there were two flaws with that idea; firstly the dismantling required for replacement of the mirror wiring loom (the sensor is part of the wiring; cannot be unplugged) - the chance of something getting broken, damaged, or refitted incorrectly seemed quite high - even removing the mirror glass was a slow and delicate task. Secondly and more importantly, I wondered about the accuracy of the sensor even when it had been working correctly; it always seemed to read a little high and I had read here of others having the same. Arguing with the dealer about how accurate it was didn’t seem constructive. Thirdly, two trips to the dealer would be needed, with no courtesy car... probably at least a day would be wasted getting there and back.

Digging the resin out of the sensor and removing the thermistor itself produced a reading of 8.5k ohms. So, its embedding in resin had been reducing the resistance to 2.7k ohms. I have never seen damp resin that has a resistance of 5000-6000 ohms or so; truly bizarre. If something’s wet, it’s usually only a few ohms, and if a connection’s corroded, it would increase resistance, not decrease it.

Connecting the thermistor by itself produced a reading of 24 degrees - obviously better than 55 degrees, but my second concern was now proven, as it was actually 19 degrees outdoors that day. I used another thermometer for comparison, plus the weather app on my phone. I was careful to keep the thermistor shaded, but it still read consistently five degrees high.

The solution was to rummage around in the junk box - you know, the kind of stuff people tell you to throw away - where I found a blended air temp sensor from inside the heater box of an Alfa Romeo 164 that I stripped for parts about eleven years ago. I measured the sensor at about 10k ohms and therefore believe it is a standard 10k ohm thermistor (the resistance of which is usually quoted at 25 degrees C). I extracted this thermistor and connected it, getting a correct reading of 19 degrees C.

I wondered about the linearity of the sensor - would it be compatible with the rather-different body computer of the Giulietta - so I devised a test involving a gel pack from the freezer. By the time I’d managed to wrap the gel pack around two sensors and get stable readings, the car and the separate thermometer gave matched readings about 5 degrees C, suggesting that at least in the useful range, the sensor seems accurate enough.

All that remained was to seal the sensor with epoxy resin, re-mount the mirror housing with its three screws (it holds the sensor in place), and - crucially - I drilled a drain hole in the underside of the mirror housing, so that water cannot submerge the sensor in the future. Did the same to the passenger door mirror and was surprised by how much water ran out of there, too. This will greatly help with drying the mirrors after washing the car - I usually have to use a leaf blower to get the sitting water out and it’s obvious this wasn’t always effective.

The final step, probably optional, was to connect MultiECUScan and clear fault codes from both the body computer and the climate control ECU - caused by unplugging the sensor, the body computer actually reads the value, and passes it along (or not) to the climate control ECU. So both will register a fault if the sensor is not present.

Also, using MultiECUScan to display parameters of the climate control ECU allows a cross check of the external temp against the four cabin temp sensors (blending air, footwell vent air, left side and right side) which should all be about the same if the car is parked in the shade without the engine/heating running. A good test, perhaps, to decide whether to replace an original sensor, even one that isn’t dramatically over-reading from being waterlogged! :)

This all seems to have made a pleasant difference to how well the climate control works - subtle heating is more effective than before, noticeable particularly in the morning. And, the fan no longer works overtime in the hotter afternoon weather. I’d always thought the slightly-high readings were from being parked in the sun, etc., but I now know that the readings can be accurate if the sensor is correct.

Cheers,
-Alex
 

Attachments

·
Registered
Joined
·
1,960 Posts
I've got an under-reading internal temperature. Very frustrating. Another poster on here sent me a new thermistor and instructions to change it, promising it would be easy. However, I was informed I needed to get some more of the plastic resin type stuff and the instructions to change the thermistor were far from easy. That was a waste of a fiver then!

If there is a simpler fix to this, I'd be very interested (and will study the notes above - although all the voltage stuff doesn't really make any sense to me!)
 

·
Registered
Joined
·
321 Posts
Agree with mru, very good post Alex. I had the same problem, temperature reading gradually increasing over a week or two, but chose to have it fixed under warranty since when it's been fine. A similar issue with my Saab 9-5 a few years ago was easily fixed - the sensor's under the front grille and could be replaced without much difficulty.
 

·
Registered
Joined
·
2,575 Posts
Discussion Starter #5
I've got an under-reading internal temperature. Very frustrating. Another poster on here sent me a new thermistor and instructions to change it, promising it would be easy. However, I was informed I needed to get some more of the plastic resin type stuff and the instructions to change the thermistor were far from easy. That was a waste of a fiver then!

If there is a simpler fix to this, I'd be very interested (and will study the notes above - although all the voltage stuff doesn't really make any sense to me!)
Heh, I suppose it’s easy compared to a full dashboard strip. Took me about one hour.
Maybe these steps...
1 - adjust driver’s door mirror inwards and downwards
2 - pull top right corner of mirror glass outwards while using thin screwdriver to release clips you can see on white plastic backing
3 - with glass removed, tease the wiring plug out of the mirror motor
4 - undo three Torx T15 screws securing mirror housing to frame (one was behind the motor plug)
5 - move housing slightly to allow sensor removal from base of housing (frame traps it in place)
6 - dig resin out of sensor using pointed tool, start with the wires - ensure that a few millimetres of fine wire are left sticking out of the terminals
7 - solder new thermistor to fine wires
8 - use epoxy resin from “$2 Shop” (translation: “Poundland”) to mount wires and thermistor back into the sensor
9 - drill drain hole in bottom of mirror housing
10 - “reassembly is a reversal of removal” (as Haynes would say) - but you get to swear in different places :)

-Alex
 

·
Registered
Joined
·
373 Posts
Suffering the the same... first sign of sun this year and an optimistic reading of 50C. Will be tackling this as soon as I’m back home.
 

·
Registered
Joined
·
4 Posts
I had the same problem of my external temperature gauge reading high. After reading this thread I purchased these 10k thermistor from ebay. Using instructions from this thread the faulty sensor was replaced and I now have a working external temperature sensor.. :lick::lick::lick:
 

·
Registered
Joined
·
410 Posts
I had the same problem of my external temperature gauge reading high. After reading this thread I purchased these 10k thermistor from ebay. Using instructions from this thread the faulty sensor was replaced and I now have a working external temperature sensor.. :lick::lick::lick:
I spent a little more for just 1 thermistor but the tolerance was 0.5% rather than 3% https://www.ebay.co.uk/p/Vishay-BC-Components-NTCLE305E4103SB-Thermistor-NTC-10k/1668031989?_trksid=p2047675.l2644 so may be more accurate
 

·
Registered
Joined
·
2,270 Posts
Thread resurrection! My outside temp is reading too high. So the dilemma is; do I fix this myself using excellent posts above or use the incompetent dealers? The car still has a warranty.
Thoughts and experiences please. The dealer is about 1hrs drive away.

Sent from my BBB100-2 using Tapatalk
 

·
Registered
Joined
·
2,575 Posts
Discussion Starter #10
Thread resurrection! My outside temp is reading too high. So the dilemma is; do I fix this myself using excellent posts above or use the incompetent dealers? The car still has a warranty.
Thoughts and experiences please. The dealer is about 1hrs drive away.

Sent from my BBB100-2 using Tapatalk
Up to you, my old replacement’s still fine; as I noted, the sensor is part of the door wiring loom, so much disassembly/possible breakage is required to fix it the official dealer way. And I don’t think they’d bother to drill you some nice drain holes in your mirrors :)

Seems like the thermistor itself is frequently faulty as well as the weird conducting resin. So perhaps the genuine replacement would just go the same way anyway.

-Alex
 

·
Registered
Joined
·
2 Posts
Fixed

Thanks AlexGS! I did the fix as you described and my outside temperature is now reading correctly - at least within +/-2degC, if not better.
I used hot glue to repot the thermistor as I did not have epoxy. Hopefully this will last.
 

·
Registered
Joined
·
2 Posts
I bought a pack of thermistors from RS, dug out the resin and soldered in the replacement, working a treat.

if anyone would like one for £2 i'll post it to them, just let me know.
 

·
Registered
Joined
·
1 Posts
Giulietta External Temperature Gauge

Hi all I have a question. My temperature gauge returned temperatures in the 80 degree C. It has eventually completely failed now, no temperature reading, and subsequently the air con now doesn't work at all, warm or warmer air only. When the reading was well off I went to the local dealership who informed me that the solution was a new wing mirror at £400+. Some of you have fixed the problem yourselves but have has anyone got the dealer to fix it out of the warranty period without taking the mirror replacement route...
 

·
Registered
Joined
·
2,390 Posts
Can't answer your question, Chris, but main dealer Ancaster at Dartford quoted much less than that to replace my mirror. I was quoted "under £100" by an auto electrician in Bromley to replace the thermistor. In the end I paid between the two quotes, having the mirror replaced at Day & Whites (Alfa specialists) at Brands Hatch.
 

·
Registered
Joined
·
8 Posts
I've got the same problem - a slowly increasing external temperature readout, which is now around 64degC.
Before I think about tackling a sensor replacement (which I admit I'm more than a bit daunted by), has anyone solved this by simply unplugging the door wiring loom and cleaning or drying that out...or am I wasting my time!
 

·
Registered
Joined
·
4,960 Posts
I've got the same problem - a slowly increasing external temperature readout, which is now around 64degC.
Before I think about tackling a sensor replacement (which I admit I'm more than a bit daunted by), has anyone solved this by simply unplugging the door wiring loom and cleaning or drying that out...or am I wasting my time!
I wasted my time doing this, i bought a new sensor see link and cut the end off and soldered on the end, saved me digging out the resin

https://www.ebay.co.uk/itm/FIAT-SENSOR-SENSOR-TEMPERATURE-AIR-EXTERNAL-71753245-FIAT-GRANDE-PUNTO-500/273443660725
 

·
Registered
Joined
·
8 Posts
Thanks for prompt response, Zoo.
I don't have soldering kit (but can maybe tap up someone who does) but apart from that, this sounds a more workable solution. I'll still have to dismantle the door mirror I guess but that sounds more like it will be just time-consuming and needing a bit of careful work rather than needing any skill.
Three more questions, if I may.
Is there an alternative to soldering the wires?
How far back did you cut them (Im guessing enough to keep it all within the wing mirror housing?)
Is it important to reconnect the wires in the right order ?
Cheers
 

·
Registered
Joined
·
4,960 Posts
Thanks for prompt response, Zoo.
I don't have soldering kit (but can maybe tap up someone who does) but apart from that, this sounds a more workable solution. I'll still have to dismantle the door mirror I guess but that sounds more like it will be just time-consuming and needing a bit of careful work rather than needing any skill.
Three more questions, if I may.
Is there an alternative to soldering the wires?
How far back did you cut them (Im guessing enough to keep it all within the wing mirror housing?)
Is it important to reconnect the wires in the right order ?
Cheers
I cut them at the sensor on the mirror wiring and stripped them, the sensor i left about 4cm then stripped it and twisted the wires together to test and taped it all up. I soldered it about a week later when i could get some more solder as id run out.

you still have to strip the mirror cover off but start to finish was no more than 20-30 mins.

no order to the wires. mines been reading fine all week and inline with local weather reports

Zoo :thumbs:
 

·
Registered
Joined
·
2,270 Posts
I prefer to use block (the plastic cubes with brass screws in tubes to bite the wires) rather than solder. You just need wire strippers and a small flat head screw driver. The temp sensor is definitely worth tackling yourself however there's a wide choice of thermistor and no one is able to confirm what resistance they need to provide.

Obviously the correct way to do it is solder then shrink wrap.
 

·
Registered
Joined
·
134 Posts
I bought a 10k Thermister and picked the glue away from the old sensor in the plastic holder then stuck it down with silicon sealer. Soldered and heat wrapped the wiring Looks perfect. Cost .99pence and took 30 mins to do.

Temp is around 2% under/over so I am happy.
 
1 - 20 of 35 Posts
Top