Alfa Romeo Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hi all, My 156 2.4 jtd 20v had a small water leak coming from the Water pump area, took it to Allitaila after Christmas when they re-opened. They diagnosed a dodgy jubilee clip on one of the top hoses and replaced it(They also fitted an new o/s sidelight,the plastic holder had snapped and charged me £56 for all the work).

Excellent, i thought end of worries!

Got back from working away last week and it was ******* water all over the place, took it to Alfatune and gus said it was the water pump, guess what, it was the water pump the water pump bearing was shaking the belt all over the place, mainly rubbing itself on the block.

A very close call i think you would agree, gus said it wouldn't of lasted another week!
The cars only done 42000 miles and FDSH.

To celebrate a bought a Stainless steel exhaust!

I know this sounds like i work for Alfatune, i dont, i just cannot believe the difference between two Alfa independants, make up your own mind.

If you've got a JTD 20V Change the waterpump and belt, i got away with it, Just.

Degs:thumbs:
 

·
Registered
Joined
·
9,912 Posts
you cant beat gus for his knowledge ,i wouldnt trust any one else with my car ,im too old lol to get my hands dirty anymore i used to blue print motors and the make own headers exhausts ,not having my own garage anymore doesnt help. if you can understand technical knowledge and listen to gus HE DOES KNOW HIS STUFF
 
1 - 2 of 2 Posts
Top