Alfa Romeo Forum banner

1 - 13 of 13 Posts
M

·
Guest
Joined
·
0 Posts
Discussion Starter #1
my engine was running really lumpy :eek: .
Turned out that only half the plugs were firing :(
I have changed the faulty coil expecting the problem to be fixed but sadly no. :rant:
Does anyone know what might be stopping one of the coil paks to stop working. :confused:

Thanks

O yes its a 155 2.0L twin spark 16V By the way
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #3
but do you know where the wires go back to? :confused:
I am going to test the two contorler units that sit under each coil in the morning as light is fading :cool:
i can follow the wires so far then they disapear under 3 or 4 relays and a few fuses.i dont know if the cables go into there or go somewhere else.
 

·
Registered
Joined
·
1,183 Posts
id start on the relays next to the batt as some of them are for the injection system, also did you check the condition of the wires supplying the coil packs make sure you are getting power to the packs with a meter on the terminals while cranking the engine. i think all the earths from the packs join to one so check the positive individually.
 

·
Registered
Joined
·
564 Posts
fletch the coils on a 16 valve earth through the metal plate they are fixed to either by being bolted to the alloy cam cover or via a wire that runs to the back of the cylinder head on the plastic can cover models. The 2 wires in the coil connectors are a constant 12 volt feed and a signal wire from the ECU.
The problem I have is that mattr has 2 coil packs and 2 controller units under them and I've never seen a 16 valve that has only 2 coil packs...... :confused: :confused:
 
M

·
Guest
Joined
·
0 Posts
Discussion Starter #7
i have 2 coil packs. they are situated on the right hand side as you look at the engine, next to the battery.
 

·
Registered
Joined
·
4,156 Posts
Sounds strange to me. Afaik al 16V have a double coil sitting on top of each spark plug.

The 8v have 2 coilpacks with ignition amplifiers fitted below them :confused:
 

·
Registered
Joined
·
564 Posts
Hoygaard said:
Sounds strange to me. Afaik al 16V have a double coil sitting on top of each spark plug.

The 8v have 2 coilpacks with ignition amplifiers fitted below them :confused:
Thats what I thought, it sounds to me as though mattr has an 8 valve 155 :) :)
 

·
Registered
Joined
·
1,183 Posts
must be an 8v , thanks for the info on the earth packs though, but im a bit miffed as i changed my coilpacks to 156 ones a while back (had to swap connectors over) and there was 4 individual wires one to each pack and then 4 other wires which all join together :confused: maybe ill install the extra earth wire now as ive done the 156 cam cover swap.
 

·
Registered
Joined
·
564 Posts
Fletch, does that mean that the coils fire the large plug and the plug next to it or have you still got the leads that run between the different cylinders :confused: because I thought that only the latest Twin Sparks used the coil to fire both plugs on the same cylinder whylst every thing up to about 2001 was basically the same as the 155 :confused:
 

·
Registered
Joined
·
1,183 Posts
im confused now :confused: what did u mean by your question ? one of my coils sparks one large plug on one cylinder and small on another.
 
1 - 13 of 13 Posts
Top