Alfa Romeo Forum banner

1 - 8 of 8 Posts
N

·
Guest
Joined
·
0 Posts
Discussion Starter #1
i remember seeing a post on this topic.

Is the gage reliable??

Mine shows 0 bars on idle, and then pretty much goes up with the rpms, until 4 bars. is that normal or should it stay between 2-4bars all the time??

N
 

·
Banned
Joined
·
477 Posts
Mine sometimes fluctuates when I have just started her up and pull away, but then settles at 4. Most times it just goes up to 4 and stays there
 

·
Registered
Joined
·
1,134 Posts
0 bars is bad - it shouldn't go less than 2.5 at idle, on a decent engine. (corrections welcome)

You should hope that your guage is shot as opposed to your oil pressure...

Up to now, my guage has proved reliable (as far as I know) - shows around 3 - 3.5 at idle when cold 2.5 - just under 3 when warm at idle and always 4 when driving (sometimes just over 4 when cold).
 

·
Registered
Joined
·
18 Posts
Hi Nicolas
I face the same problem ('93 8V)
On warm engine, pressure is near zero. He comes back to normal 4 bar just around 3500 rpm
I wonder why the warning light is not going on. Either the pressure is enough, just gage and/or indicator is bad, or pressure is NOK then light is bed and I have an engine problem.
I intend to check the pressure with an external manometer.
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #5
From memory I think the manual just says it should be more than 2.5 bar at full revs (presumably in neutral, rather than driving along). I await correction wink

But mine is usually around 4 driving and idling. 6 at start up when cold, and also goes up to about 5 or 6 when you floor the loud pedal.
 
N

·
Guest
Joined
·
0 Posts
Discussion Starter #6
i added a quarter of oil today. the gage went up to 1.5-2 on idle and just over 4 driving at 3500-4000rpm.But after driving and then on idle it was close to 0 again. there is no oil leak i checked under the car, so i think its just not enough oil. i intend to add another quarter of oil today and see what happens. The oil warning lamp comes on when the car is standing in a hill, which it did today, so i belive its just a question of more oil. These chain cars tend to use more oil than regular belts, i belive??

Thanks

N
 

·
Registered
Joined
·
4,651 Posts
SUGGEST YOU CHECK OIL LEVEL WITH DIPSTICK WHEN PARKED ON LEVEL GROUND AND FILL IT CORRECTLY eek! rather than putting a bit in till gauge reads higher eek!
 
D

·
Guest
Joined
·
0 Posts
Discussion Starter #8
Mine is always on 0bars :(

I need to repair this, but i don't know how!

If I change the sensor... can repair this or can be fuse (I think this is not posible...) or cut on the circuit?
 
1 - 8 of 8 Posts
Top