Alfa Romeo Forum banner

1 - 3 of 3 Posts
R

·
Guest
Joined
·
0 Posts
Discussion Starter #1
I've sprung a leak! It is somewhere near the back of the engine, higher than the offside driveshaft - engine oil seems to be being flung around by that. The bottom of the alternator, the steering rack, sump, floor pan and even the rear spring pan and rear exhaust are covered with various amounts. With everything cleaned up and the engine running I reckon it is coming from the oil cooler pipe where it joins the engine near the oil filter. There is about 1 drip every 2 seconds (but only with the engine running). I think that it has just happened and I have caught it in time, the oil level never went below the minimum mark.

I see from the service records that the oil cooler and both pipes where replaced exactly 1 year ago today. (Oil cooler £137, both pipes £124) They don't look corroded. My best guess is that the pipe has a small fracture.

Anyone had anything similar happen? If it is not this pipe, is there anything close by that may also leak? It is definitely engine oil, not power steering or gearbox oil. Thanks in advance.
 

·
Registered
Joined
·
2,998 Posts
If it's oil cooler pipes it'll be dripping on the right hand side of the car just inside and behind the front wheel.

The oil cooler pipes are known to corrode on the V6, it's one of their things. When the new ones were installed they should have been greased up.

If you can get underneath the car have a look.

Unfortunately most garages will change the filter at the same time as the pipes as it's difficult to remove just the pipes, but that's not always the case.
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #3
Thanks.

I've been under and oil is running down the pipe, possibly from the banjo nut. The pipes do not appear corroded and are exactly 1 year old today. I'll try to get a closer look tomorrow.
 
1 - 3 of 3 Posts
Top