Alfa Romeo Forum banner
1 - 6 of 6 Posts
G

·
Discussion Starter · #1 ·
I noticed earlier whilst at a set of lights and with girlfriend and her Red Setter in the car, that the coolant (?!)temperature had soared to just over 100. I regularly check the gauge due to a previous cooking of my old MR2 and so knew that I hadn't gone very far like it. I had filled the coolant last weekend to the recommended level, yet when I opened the bonnet the coolant was barely to be seen in the tank - bar a worrying telltale boiling up where the hose connects (bottom right). I took it to the garage 2 minutes down the road and asked the mechanic there to have a look. At first he thought the thermostat had gone (two previous head gasket killing failures on this car prior to my ownership) but then I noticed a small patch of water on the ground underneath the car, the source of which was the oil cooler. Has anyone got any experience of this part failing before? It really does flow pretty fast as the engine cools and is obviously really concerning. Any advice would be very much appreciated...

------------------
 

·
Registered
Joined
·
1,134 Posts
There isn't any water in an oil cooler, just oil! Incidentally, where is the oil cooler - I don't think mine has one!
 
G

·
Discussion Starter · #3 ·
Yes, so I'm told Richward, I didn't know but was informed it was the oil cooler by a mechanic who obviously knew about as much as me! If you look just above the oil filter there is a small metal pipe that branches off from where the filter attaches. That's where the coolant is leaking from.
 
G

·
Discussion Starter · #4 ·
Hi guys
If you check in front of the water radiator is a slimmer and lower radiator which is the oil cooling rad.
What is your opinion of the "alfaowner.co.uk" web. Just been they once but I find it a bit comfusing.
Well, it's a good thing that we still have a place to go to get and contributing advise on our alfas.
Regards
Erik
 
G

·
Discussion Starter · #5 ·
The oil cooler on our cars is the part where the two rubber hoses connects to the oil filter. It a water cooled oil cooler, not an air cooled oil cooler.
When your oil temp is high, so should the water temp be.
 
G

·
Discussion Starter · #6 ·
Understandably I was a touch confused because I was told I had a leaking oil cooler and then I was told that there is no oil cooler! I traced the leak to a pinhole on the metal pipe which runs really close to the oil filter. Araldite did the job and (TOUCH WOOD) so far no further problems!
 
1 - 6 of 6 Posts
Top