Alfa Romeo Forum banner
1 - 20 of 28 Posts

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #1 ·
Well it had to be didn't it.:lol: So got it health checked for the mrs as I wasn't convinced the rear discs and pads were contacting properly and I wanted to investigate the flat spot between 2.5/3k rpm.

So this is what is wrong with an 8000 mile car..

1. P1524 Spark plug anti foul diagniostic. mechanical linkage failure. 39 occurrences
2. P2299 Brake/accelerator coherence
3. Poor pad contact on rear discs. 10% in inside face
4. Disc badly pitted and rusty
5. RH rear speaker has interference coming through it and buzzes until tapped every time you start the car.

Oh dear. This should have been picked up by the sales people :tut:
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #3 ·
That was my thinking. I have already spoken to them and I am now waiting for a call frol a local dealer as we both agreed it was too far to travel 6 hours to get back to them.
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #4 ·
Just had a call from Meridien Milano. Booked in for wednesday morning. Well done to them and Desira for acting swiftly :thumbs:
 

·
Registered
Joined
·
1,782 Posts
Just had a call from Meridien Milano. Booked in for wednesday morning. Well done to them and Desira for acting swiftly :thumbs:
Have you had many dealings with them before?

I had mostly good things with them, but once they really messed up my gearbox and had to put a new one in...
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #6 ·
Yes a bit in the past but only spare parts and sales
 

·
Registered
Joined
·
403 Posts
Sorry to hear this, real bummer, hope it gets sorted with minimum fuss.
Is p1524 multiair related? States mechanical so wondered is it to do with the hydraulic tappets etc??
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #8 ·
At the moment I don't know but I'll keep you posted.
 

·
Registered
Joined
·
30 Posts
Sorry to hear your dealer let you down ,my dealer isn't mush better ,they forgot to pdi it ,they forgot to give e back my refundable deposit,they stuck the front number plate straight on to the bumper,i removed it and fitted the adaptor (found in the boot ) and refitted the number plate..Being in the trade myself I was mellow about it ,I didn't kick off ..4 month in to ownership did a 1000 mile round trip..Stop start didn't work ..So called them to book it in when I got home..Tey obviously forgo who I am, as I was for some reason put through to the salesman who sold me the car,and he started with the bull...When I reminded him I was in the trade and work in a truck dealership,and we also do Fiat professional (I don't ,hate vans )I have been getting regular battery health checks,from the Fiat Alfa Chrysler battery tester,and when the Fiat troubleshooter was at our place I gt hi to have a quick look and he confirmed there is an issue .He folded like a pack of cards saying they will fit a new battery...I work on the 3 Cs Complaint, Cause ,Cure ..I give them the complaint and when I pick the vehicle up I ask the cause and the cure,they do not like that lol
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #11 ·
Well lets see if it gets resolved tomorrow. I've made the first C.
 

·
Registered
Joined
·
454 Posts
i know this feeling all too well
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #14 ·
Well it's been a bit of a faff but we are making progress.

Rebooked for this thursday after an inspection last week. Disc replacement has been authorised. (Thank you James from Desira) fault codes were cleared. I have been told this fault can happen when a car spends some time at a dealer and is then moved about a lot so it doesn't warm up and ends up fouling the plugs. It will be checked again this thursday to make sure it hasn't re appeared. If so it will be investigated. Speaker to be replaced. This will be courtesy of meridien so thanks to rob for sorting this out.

I've booked it in for paint too as the front bumper had a scuff and I drove it into the back of my BMW at the weekend while moving it around which left two marks by the grille :rolleyes:
 

·
Registered
Joined
·
403 Posts
Good to hear you have at least got them to acknowledge some of faults.
BUT- "fault codes were cleared. I have been told this fault can happen when a car spends some time at a dealer and is then moved about a lot so it doesn't warm up and ends up fouling the plugs". This actually made me laugh- what an absolute load of codswallop!!!
Not only the fact that moving it a few times would cause a fault code- the fact is a fault code is thrown up for a reason, if they plug it in they should know exactly what caused it so insist they do this and fix it.
Ask them to explain and if possible show you what they have done, otherwise they will just tell you they have checked it and code hasn't re-appeared. Result?- a trip back to dealer with same fault.
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #16 ·
Its fine mate. I'll be checking it with my specialist after anyway so if it does pop up they'll be caught out. Never said I believed them but if they want to see the car for a third time then that is their choice. For now this is their reasoning so I'm happy to let it pan out as they are sorting the other bits. The flat spot has seemed a lot less obvious of late so I'm wondering if its just spent it's life doing really short journeys and is a bit clogged up. Time will tell.
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #18 ·
:lol: seasoned pro? I think not. I know nothing about anything me ;) :thumbs: the best way to be IMO. As long as it all comes good in the end I'm happy with their service.
 

·
Premium Member
Joined
·
19,119 Posts
Discussion Starter · #20 ·
You bought your new Mito yet? :)
 
1 - 20 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top