Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
ok did a bit of playing and disconected the battery !!


the key fob doesnt work battery but the alarm keeps going off is there any other way to deactivate uk so dont have alarm key i have 4 keys burgandy and 2 red is there anyway to stop the noice other than key fob ?



cheers
 

·
Regional Support, For Lincolnshire - AOL
Joined
·
16,340 Posts
Not sure about this but IIRC the alarm is under the Plastic Cover on the Drivers side under the Bonnet, I think that there is a panel on this that pulls off so you can see the Module. I think that there is a mechanical type key that can then turn off the Alarm.

Not at all sure about this as mine was removed years ago but if you do a Search you'll find lots of info about Alarm problems.
 

·
Registered
Joined
·
1,292 Posts
What year/phase is your GTV?

There are 3 types of alarms that Alfa had installed. I believe that Phase 1 cars had a Scorpion 918U alarm fitted. Phase 2/3 cars have either an Alfa alarm fitted (Import) or the infamous Meta M99 alarms. If you need any info on the Meta alarm system the go to this website Abacus Car Alarms.

The Scorpion ECU lives behind the instrument cluster. I don't have much info on this alarm, I believe it is discontinued.

The Alfa alarm can be identified by having the alarm fob integral with the key and the alarm receiver is located in the interior light housing and the alarm ECU/Siren is under the offside plastic cowl in the engine bay.

The Meta ECU lives in the centre console and the siren is located the same as the Alfa alarm. To disable the Meta system all you have to do is to remove the plugs on the ECU. Be aware when you do this you will loose the remote central locking function whilst the alarm is disconnected.

Please note that the Alarm and Immobiliser (CODE), are 2 separate systems.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
thanks for the info m8................ luckly new batteries in the fob worked i can get in my car now without upsetting the neigbours lol


cheers
 

·
Registered
Joined
·
236 Posts
Sorry JaseGTV are you saying the alarm started having issues after you had disconnected and reconnected the alarm? if so I had the same issue and I might be able to help you fix it :thumbs:
 

·
Registered
Joined
·
20 Posts
Discussion Starter #9
thnks for the shout jimmy.................key fob wasnt working that well so didnt use it...


but i disconected the battery and then found out i had to use keyfob to turn alarm off ....dead batteries in keyfob bought new ones and now using it fine everthing sorted but thnks for the shout


cheers
 

·
Registered
Joined
·
5 Posts
am having same problem. Battery went dead. Have fitted new one and now the central lockings packed up and alarm keeps going off. Help!
 
1 - 10 of 10 Posts
Top