Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,989 Posts
Discussion Starter #1
As seems to be the case with some Alfas, you fix one thing and something else goes wrong. I've just changed the clutch slave cylinder - not for the faint-hearted and now I have an odd knocking sound/sensation.

Sometimes, when you start the car up there is a knock from underneath somewhere. Then, when going over a slightly bumpy road, the thumps/knocks can be felt through the floor. It's not horrendous but a definite noise. I had something similar before and it turned out to be the exhaust hitting somewhere underneath. A few adjustments and it went away.

I'm wondering if the same thing is happening again but I have the exhaust a vigorous wiggle around and it seems to be OK unless it's an up/down issue.

I was told it could be a bush on top of the bellhousing or an engine mount. Need to investigate further....

Any ideas!?
 

·
Premium Member
Joined
·
38 Posts
Dose the clunk happen when you come on and off the power?
Is it worse in lower gears?
Diff mountings are also worth checking.
 

·
Registered
Joined
·
1,989 Posts
Discussion Starter #3
Dose the clunk happen when you come on and off the power?
Is it worse in lower gears?
Diff mountings are also worth checking.
No, just on start-up and going over bumps in the road. I wonder if it's the exhaust hitting underneath. It did something similar before. It's just that I've given the exhaust a good wiggle and all appears to be ok.

It feels like a bush of some sort. Will have to get it up in the air...
 

·
Registered
Joined
·
1,989 Posts
Discussion Starter #5
Have you checked the prop shaft doughnuts??
There is no vibration from the donuts but will check when I can get the car on a ramp!
 
1 - 5 of 5 Posts
Top