Alfa Romeo Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
215 Posts
Discussion Starter #1
hi all,
have a random power problem. when driving very occasionally I get a hicup from the engine, a slight blip. (felt like a old fashioned carb fuel blockage for a split second)

also while driving, it feels sometimes it is down on power one moment (less power under 2k), and then fine the next moment.. (maf?)

the EGR has been removed, cleaned and rebuilt and doubt it is that. . Also no dash lights come on if it has a blip..

any ideas.?


stz
 

·
Premium Member
Joined
·
19,119 Posts
is it literally a blip as in 10th of a second sort of thing around 1500-2500 rpm area? If so mine has the same. Its just poor mapping from the factory apparently.
 

·
Registered
Joined
·
215 Posts
Discussion Starter #3
ye

hi,
yea, it seems to be random, i had a blip a 1100rpm, and another time it was 1500rpm or so.. bit wierd, scared me a b it when going uphill.. I thought ohno whats happened..

But the slight loss in power is a seperate issue. Occasionally it seems like a rocket ship.. and a few minutes later a bit sluggish under 2krpm..
 

·
Registered
Joined
·
4,241 Posts
Egr valve?
 

·
Premium Member
Joined
·
19,119 Posts
hmm yeah I'd go with tom and say go back to your egr valve. I know its been cleaned but several people on here have done the same only to have the problem continue until they do it again. Altrnatively get a remap and block the egr valve off. No more woes! :clap:
 

·
Registered
Joined
·
215 Posts
Discussion Starter #6
It feels like the EGR valve, power only seems to appear when the boost builds up alot.

..could be the solenoid is jamming ocassionally, I think I'll give the EGR solenoid a squirt of lube from behind where I have made the small hole to tap out the internals, might make the different..

atb

stef
 

·
Premium Member
Joined
·
19,119 Posts
keep us posted
 

·
Registered
Joined
·
910 Posts
Check the small hose from the turbo boost valve on the top left of the rad , it's about the size of a washer pipe , they are prone to split , have a good check I pulled mine of to find it it's only about 6inches long.
 

·
Registered
Joined
·
586 Posts
Did you clean inside the solenoid also?
 

·
Registered
Joined
·
215 Posts
Discussion Starter #10
yep, solenoid stripped down cleaned and rebuilt.
 
1 - 11 of 11 Posts
Top