Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
17 Posts
Discussion Starter #1
Hi all,

Bought my first Alfa 2 days ago, a 2009 159 2.0 JTDM Ti.
Stunning car, although had my first problem, hopefully not a pattern emerging !

I had the engine light come on with a fault code P0131 read, O2 Sensor.
Can anyone shed any light on this ? A common fault at all ? Also, where abouts in the exhaust is the sensor mounted ?

Thanks
 

·
Registered
Joined
·
4,802 Posts
O2 sensor is the MAF, if purchased from a dealer, they should sort it. Likely was an issue before. You can try cleaning it, but they do die. They are a bit expensive, but do recommend a proper Bosch one.


Sent from AutoGuide.com Free App[/color
 

·
Registered
Joined
·
17 Posts
Discussion Starter #3
O2 sensor is the MAF, if purchased from a dealer, they should sort it. Likely was an issue before. You can try cleaning it, but they do die. They are a bit expensive, but do recommend a proper Bosch one.


Sent from AutoGuide.com Free App[/color
Thanks for the reply.

Oh really, i read on alfaworkshop that the 2 problems can be linked, but surely if i have a fault code pointing to the O2 sensor, isnt that more likely ?

I can try to give the MAF a clean though. Purchased privately
 

·
Registered
Joined
·
4,802 Posts

·
Registered
Joined
·
564 Posts
Hi T5,

Congrats on your purchase, these are really nice motors to drive.

Please study the advice I gave some fellow member before and for the same issue:
http://www.alfaowner.com/Forum/alfa...ider/699698-p0130-fault-code-on-2-0-jtdm.html

(See posts #10 + 11 for answers to both your questions. Btw MAF sensors do go rarely broken on these, if you see problems with MAF values it most of the times is related to EGR issues).

Trust this will help you further, enjoy your car once fixed again.

Cheers, Leo
 

·
Registered
Joined
·
17 Posts
Discussion Starter #6
As a follow up. As the sensor warning appeared oddly at exactly the same time as the fuel light came on i put it down to a one off. I cleared the code and since then nothing has reappeared. Wait and see i guess.
 
1 - 6 of 6 Posts
Top