Alfa Romeo Forum banner
1 - 20 of 21 Posts
G

·
Discussion Starter · #1 ·
I'm beginning to hate the V6.

Now it won't rev properly.

Rev quickly it sounds like it's hitting the rev limiter at 2500rpm.
Build up slowly and it does it at 3500rpm.

What is going on ???

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAARGH !!!!
 

·
Registered
Joined
·
4,651 Posts
Think Jack`s right someone else had this problem

Just a thought .............but have you got the connections to the fuel pump tight in case it`s loosing fuel pressure :confused: But more likely to be the crankshaft sensor contacts or the sensor itself :(

Afraid to say mate but you always get more problems on a car thats been stood for a while ..............they dont like it and need to be driven lots and lots and lots
 
G

·
Discussion Starter · #5 ·
It appears it could be water either in the spark plug wells or the cam timing sensor. My car does it cold and hot. The other reports were only when hot. We did have mega rain for a couple of minutes yesterday.
 
G

·
Discussion Starter · #9 ·
yep induction kit on. I'll go and disconnect the AFM. The car won't rev with it disconnected though, I know that from the Silverstone.
 
G

·
Discussion Starter · #11 ·
Now it gets too 5500rpm before going funky.
I tightend up the screws on the throttle body to make sure there wasn't an air leak. I reckon the gasket has gone.
Aaah well, got some instant gasket in the shed to try :rolleyes:
 
G

·
Discussion Starter · #12 ·
Mr T came along with his Data Book and we tested the AFM, air temp sensor and lambda values....all correct.....which is great news. Nothing else seems to be amiss.

After the testing, the car revved freely up to the Redline :confused:

Mr T has gifted hands and has blessed my car good vibes I'm sure !!!!

Cheers Neil :)
 

·
Registered
Joined
·
4,651 Posts
marlon said:
Mr T came along with his Data Book and we tested the AFM, air temp sensor and lambda values....all correct.....which is great news. Nothing else seems to be amiss.

After the testing, the car revved freely up to the Redline :confused:

Mr T has gifted hands and has blessed my car good vibes I'm sure !!!!

Cheers Neil :)

Well for CHRISTS SAKE STOP MESSING ABOUT WITH IT while its running sweet :p :p :D :D

Probably be a poor connection on a wiring plug............brought on by too much Tinkering :p :p :cheese:
 

·
Registered
Joined
·
993 Posts
marlon said:
Mr T came along with his Data Book and we tested the AFM, air temp sensor and lambda values....all correct.....which is great news. Nothing else seems to be amiss.

After the testing, the car revved freely up to the Redline :confused:

Mr T has gifted hands and has blessed my car good vibes I'm sure !!!!

Cheers Neil :)
Does this mean I have to change my forum name to the Rev T and bless all the Alfas?
 
G

·
Discussion Starter · #16 ·
as long as you don't move from the street you can call yourself whatever you like ;)

Jason loved the V6 and I'm sure he's gonna tell Arja that he needs to upgrade as the 16v is gonna die soon :lol:
 
G

·
Discussion Starter · #17 ·
hmm need to make mine faster than marlon's now :D

love that V6 noise tho... lovverly

we need to go on a run up the backroads tho

j
 
1 - 20 of 21 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top