Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi,

So I’m slowly going through any niggles on the 159 1.9 2007 150bhp I bought last week. One of the main things that is quite annoying is soon as put 1 bar of the fans on, quite an annoying wering sound starts which gets louder the faster you go.

At a complete shot in the dark something to do with worn fan or air con unit? I don’t know much about mechanics, I’ll likely take it to local mechanic but wondering if this might be something that has come up before?
Cheers.
 

·
Registered
Joined
·
2,945 Posts
I read not that long ago that the AC system in the 159 can make a muted whooshing sound when switched on due to lack of AC gas pressure.
Does it make a difference to noise of fan if AC is switched on or off?
These are 2 separate systems integrated into the one climate control system.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
I thought at first when turned aircon off but left fans on, the noise went, however seems to stay on regardless if air con activated or not when fans are on now. Soon as turn off the fans, no noise.

I will double check this though as I did think would be AC related.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Thanks for the link to the other thread, that does sound very similar. Not sure if my amateur skills up the task but least can get someone who knows what they doing to have a go. Very much appreciated! Cheers
 
1 - 6 of 6 Posts
Top