Alfa Romeo Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
610 Posts
Discussion Starter #1
Hi Guys



Maybe some of you can give a few pointers.

My Gt Jtd seem to go flat after 2750rpm from 3rd gear onwards, Its like there no power and acceleration is non existent, 1st and 2nd seem ok but 3 and onwards is really noticeable.
 

·
Registered
Joined
·
1,589 Posts
any warning lights or anything like that?

that is about the RPM that the turbo should move into maximum beans mode for max boost, so you are either not getting the turbo to move into max pressure mode, which is unlikely as if all the VNT stuff breaks down it defaults to this mode, or you have a boost leak.

I would plug her into a laptop and check boost pressure vs target pressure and let us know what you see.
 

·
Registered
Joined
·
338 Posts
sounds like a split turbo hose or your EGR valve needs cleaning out... could even be to do with an airfilter or so on...

you should get an error code if its anything major... any flashing dashboard lights/warnings?

I have code reader and scan software if you need to check it out...
 

·
Registered
Joined
·
610 Posts
Discussion Starter #4
No errors at all, Maybe it could be to do with me cleaning the egr out last wkend ? Under power it doesnt smoke at all which is strange.
 

·
Registered
Joined
·
610 Posts
Discussion Starter #7
well i decided to clean it after it was becoming hesitate below 2.5krpm it started to play up about 2 days after. I wasnt aware it can cause upper rev problems to:rolleyes:
 
1 - 7 of 7 Posts
Top