Alfa Romeo Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I bought an ex Fiat management Giulietta Cloverleaf last November. It looked like new, had done 7.5k so I expected it would be perfect.
Amongst a number of issues it had the gearbox 1st and 2nd gear difficulty. The syncros were changed last week, cured the problem but now dna does not work. Dealer does not know why, no error shows up on diagnostics and I am now waiting for them to get words of wisdom from Alfa technical support.
By not working I mean nothing happens when keeping accelerator steady and moving from n to d. Nothing, carries on accelerating but no "kick" like there should be.
Has anyone experienced this before?
 

·
Premium Member
Joined
·
42,855 Posts
The only problem Ithought I had with the DNA system in the Mito was when I tried to go from N to D mode when traveling above 60mph. Apparently you have to be below 60mph. :eek:
 

·
Registered
Joined
·
34,428 Posts
I bought an ex Fiat management Giulietta Cloverleaf last November. It looked like new, had done 7.5k so I expected it would be perfect.
Amongst a number of issues it had the gearbox 1st and 2nd gear difficulty. The syncros were changed last week, cured the problem but now dna does not work. Dealer does not know why, no error shows up on diagnostics and I am now waiting for them to get words of wisdom from Alfa technical support.
By not working I mean nothing happens when keeping accelerator steady and moving from n to d. Nothing, carries on accelerating but no "kick" like there should be.
Has anyone experienced this before?
try another dealer.(If you are selecting D when you are going over 50mph ,nothing will happen anyway)
 
R

·
Guest
Joined
·
0 Posts
It's 70 mph. Does the display change and the light on the switch go from N to D (Orange)?
 

·
Registered
Joined
·
114 Posts
Yes not sure of the details yet but I had the grin wiped off my new Alfa owner face last night on the M1 when my new pride and joy told me "Dynamic unavailable" :( :cry:

After pulling in behind a slow truck to scowl at the dash for a while
D mode activated, scotty engaged warp, and the scaled cat got properly out of its box :)

Ahhh blessed relief - there is a speed limit to engaging D

Hope you get normal service resumed soon if its more serious than noob user
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thanks for your input and suggestions. It doesn't work at low speeds in any gear, although the display and light on switch both work. Strange it worked before the syncros were changed, I don't see why that should affect the dna.
 

·
Registered
Joined
·
15 Posts
I've had similar problems with DNA when the car had only 450km! There was a faulty timing valve or sensor. After replacement and software update the Dynamic or AllWeather have been available at all times. The car still forgets the mode it was before when starting the motor. According to the manual it should remember if it was on all-weather mode. When the key is in 'mar' - before starting - the previous mode is still engaged. Just after the key is turned to start the motor there's a millisecond glimpse of the screen saying 'dynamic not available' and it returns to normal mode. After this the dynamic or all-weather can still be selected. Seems like a power spike that resets the memory.
 

·
Registered
Joined
·
1,480 Posts
nasty - hope you get it fixed.
took me ages to realise that it needs 3 seconds of holding the switch at a speed under [x]mph before it will move from N to D, I was pushing it once and letting it go, and nothing happened...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #9
Well I now have the Cloverleaf back working how it should! The dealer told me they changed the ecu to see if that would cure the problem - and it did. Had to wait a week though for a replacement to arrive from italy! With my dna restored I can now enjoy the car again!
 

·
Registered
Joined
·
1,768 Posts
Well I now have the Cloverleaf back working how it should! The dealer told me they changed the ecu to see if that would cure the problem - and it did. Had to wait a week though for a replacement to arrive from italy! With my dna restored I can now enjoy the car again!
Excellent. Glad its sorted :thumbs: Have fun :D
 
1 - 10 of 10 Posts
Top