Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
hi have owned my 166 3.0 for a while and love it but the other day while driving home late i pressed the brake pedal to be greeted by a pop and all brakes had disapeard,causing me to drive 2 miles on the handbrake has anybody any idea what on earth has happened?
 

·
Registered
Joined
·
1,021 Posts
hi have owned my 166 3.0 for a while and love it but the other day while driving home late i pressed the brake pedal to be greeted by a pop and all brakes had disapeard,causing me to drive 2 miles on the handbrake has anybody any idea what on earth has happened?
You've soiled your trousers? :lol:
 

·
Registered
Joined
·
2,518 Posts
For real? You come across in your description as being so calm and collected about this... You didn't sh|t yourself???

If you heard a pop, then maybe you blew your brake master. Don't mess with this and have the whole thing inpsected by a pro though. You were lucky if you managed to stop safely.
 

·
Registered
Joined
·
6,300 Posts
'kin hell - that would be scary! I thought dual circuit systems were designed to avoid this so that a major failure in the pipework etc meant you still had braking on one front and one rear? My brake pipes that failed the MOT apparently were really bad in parts and the mechanic said that if i braked really hard i might have blown them....scary thought!
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
thanks guys could be the pipes am a semi skilled mechanic so will have a look tomorrow, am in the middle of doing all the shocks and springs what a lovely job......... not
 
1 - 6 of 6 Posts
Top