Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
487 Posts
Discussion Starter #1 (Edited)
The 1.9 159 threw a wobble today ...

The car had driven 20 mile and then there was a lot of jerking and a pluum of smoke out the back, It didnt look black smoke as you'd expect with a split pipe , it wasnt white like a failing turbo and it wasnt blue from oil ...
The car seemed to settle down for the next 300yards untill i came to a junction and i stalled it while pulling away as under load it wouldnt rev or slow to upto 2.5krpms, i had to get it 2/3k rps and ride the clutch to get away from the junction but once it reached 3k rpm it pulled away reasonable well ...
I wasnt in limp mode as it would rev till the red line ..
During this time i kept dipping the clutch and revved the nuts off it to see if it was still chucking out smoke to see if it i'd got a split pipe but there was no smoke and none for the rest of the journey.
I pulled over and popped the bonnet and the water in the expansion tank was well over the max mark which worried me but the temp gauge was sitting at 90,
Anyway, The lack of power and low revs went on for about 20 minuts and then it seemed to clear and it's back to normal pully away as it should so ... What on earth could be the cause ?
I thought that it might be a regen but there was no warning on th dash or anything ...
Once ive had me tea i'll stick it on multiecuscan but there's no dash light lite so what do you recon ?

Edit : Additional info is that its a nightmare starting from cold and when i checked the injectors a few months ago #3 is very high at 5 mm3/i's
 

·
Vendor
Joined
·
45,462 Posts
Could be EGR valve stuck open - engine is being flooded with exhaust gas.

#3 injector circuits are prone to failing, you might need a new plug on the loom for this injector. You could also have a failed injector here or low compression on this cylinder (perhaps caused by sucking in a swirl flap).
 

·
Registered
Joined
·
487 Posts
Discussion Starter #3
Ive just plugged in Multiecuscan and there's no faults.
I tried to start it and again it struggles, it turns over and tries to fire but repeatedly doesnt ..
The injector readings at tick over are
#1 0.50
#2 -2.50
#3 5.12
#4 -3.40

At 2.5rpm's they're ..

#1 -1.70
#2 0.56
#3 2.10
#4 -1.27

Mentioning the swirl flaps, recently i had noticed a clatter/noise which seemed to be the right hind side of the inlet manifold , i'll have to strip the egr tomorrow and check that but the rest will have to wait till christmas holidays
 

·
Vendor
Joined
·
45,462 Posts
Would be worth doing a compression test through the glowplug holes. That will either point to an issue with cylinder 3 or prove the engine to be inherently OK, and then you can look at other causes such as EGR, fuel system etc.
 

·
Registered
Joined
·
487 Posts
Discussion Starter #5
((((( Sigh )))))


On my 147 i had a high number 3 injector which cleared when i cleaned out the end of the inlet manifold where it's double skinned and directs air to the egr, so with that in mind today i removed the egr, butterfly valve and the metal double skinned section which then bolts to the plasic manifold.
The doulble skinned section was completley clogged so cleaned untill spotless alond with the butterfly valve and ive but all back together .... Now it wont start !?
Everything is plugged it , everything is tight and eveything is back where it should be but it just turns over and fire.
Plugged in Multie scan and no errors so it looks like tomorow im walking to work .
:grumpy:
 

·
Registered
Joined
·
487 Posts
Discussion Starter #6
So over night ive decided to remove the swirl flaps from this plastic manifold or at least get the manifold off as its very dirty with an oily mix to cleanit out.
No i know about bolting the fuel pump cog save removing the cam belt so is it just a matter of removing the 3 pumps bolts then the large front cog nut and prising the pump away ? are there nya small componants likely to drop ?
Along with the pump what else needs to be removed ? The black oil catcher (isit ?) and its bracket along with the vacuum tank on the back of the engine, the egr and butterfly valve will also be off the car ...
Then undoing the manifold bolts and does it pull away or is it attacted by the swirl valves ...
I know I'm going against advise doing things arse over breast and should get it compression tested first but it was a 450 ebay find 6 months ago and if it's pooped then id rather know now ...
 
1 - 6 of 6 Posts
Top