Alfa Romeo Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
230 Posts
Discussion Starter #1
New to the ways of Alfa switches 7 wiring - daft question, but does anyone know how to release the temperature sender switch i.e. the plug on the top of the sender unit. Have tried every which way and am concerned I'm going to break it!!
 

·
Registered
Joined
·
12,881 Posts
On mine anyway there is a clip on the outside of the stat holding it on ... (hard to describe really) ...
 

·
Registered
Joined
·
230 Posts
Discussion Starter #3
Never has a wiring plug got me beat, but this one has. I was planning to change my thermostat tomorrow but needed to check that the new sender unit has the same wiring pins as the old. BUT, I cannot get the sender unit wiring plug off. The release clips (?) are facing the rear of the engine and I cannot see how it unclips. I've tried everything short of breaking it! I'm probably being really dim, but can anyone give me a clue (photo would be great)
 

·
Registered
Joined
·
30,017 Posts
It isn't Alfa specific.
I'm sure it is a std AMP plug.
There is a tab to squeeze, but they often need the other end of that tab lifting with a small screwdriver.

As I said, std plug, not an "Alfa" issue (except that the plug you have an issue with is on an Alfa!)
 

·
Registered
Joined
·
230 Posts
Discussion Starter #5
Still no joy - this is so frustrating! Does anyone have a close up photo of the sender & plug - preferably with the plug removed so I can see how the hell to get it off!
 

·
Registered
Joined
·
12,881 Posts
don't know if this picture helps (from a 1.8 TS) ...
 
1 - 6 of 6 Posts
Top