Alfa Romeo Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Morning everyone,
I have recently purchased a low mileage (24k) 3.2 Prodrive Brera from an Alfa specialist in London.
I have a few questions and rather than do loads of posts thought I'd condense them into a single rambling one.
Bear with me.
I have never owned an Alfa before so its all been a bit of a learning curve.
So here are a few questions to the experienced among you - any thoughts welcome.

1. The car doesn't have the 'correct' Prodrive back box on it - it has 4 rectangular stainless pipes sticking out the back. Everything else seems in order and is denoted an 'S' on the v5 - has anyone else seen these pipes as standard? It seems odd that someone would change them on a low mileage car and there is no record of an accident.

2. When driving the car at about 2500rpm and accelerating gently there is a loud booming in the cabin which I'm not sure is Induction roar or Exhaust resonance. Is this a 'feature'?
Other than this area the car is quiet(ish) in the cabin with just the great sound exhaust note present.

3. Blue and Me. I have a Blue and Me manual along with Owners handbook. There are buttons on the Steering Wheel and an iPod connector lead dangling in the glove box. But I'm fairly sure that its not fitted in the car as I cannot activate it or find a Menu option for it.
Have Alfa given me a book for a laugh or is there a hidden 'Turn on' function somewhere?

And in case anyone is considering a different tyre size...
When I bought the car it had a mix of tyres front and rear with Vredestein on the front. These were awful in the wet and squealed in the dry. At the first opportunity I swapped them out and went for a full set of Dunlop Sport Maxx tyres. I went for a wider 245/40/19 size primarily to protect the rims. They have so much more grip wet and dry but can occasionally seem noisy. There is an 8mm larger overall diameter which has caused no issues.

That's all for now and I promise to be a bit more focussed next time I post.
thanks
Bob
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Hi - thanks for the reply. It's all very complicated!
I phoned Alfa Customer care - they confirmed it was a Prodrive car which is why the non 'standard' rear exhaust box seems odd.
Not that bothered as it sounds great.
 

·
Registered
Joined
·
1,066 Posts
Sounds like the Blue and Me is there somewhere. I can't remember exactly how I got mine working but it was a bit of pain to get it to pair with my phone. I think there were more than one type of Prodrive exhaust produced looking at pictures. As long as you don't have the awful standard back boxes it shouldn't be too bad.



Take it back to the garage and see if they can answer your questions (sounds like Veloces...).
 

Attachments

·
Registered
Joined
·
3 Posts
Discussion Starter #5
these are my exhausts if anyone can identify them!

Yes I think a call to Veloces is in order as I'm out of ideas on B&M
 

Attachments

1 - 5 of 5 Posts
Top